Class definition mission

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
dgxhubbard
Posts: 42
Joined: Fri 14 Aug 2015 20:58

Class definition mission

Post by dgxhubbard » Fri 14 Aug 2015 21:03

I just downloaded ed 5.8 and used it to regenerate our model after update our sqlite and sql server databases. I have a huge problem. One of the classes did not get generated from the database. When I update the model from the database for both sqlite and sql server the class is in the list, but when I try to find the class in the explorer > classes it is missing. The table name was SecurityGroupLinks and that was missing so then I changed it to SecurityLinks and it is still missing. What is wrong with this. I need to get a resolution as soon as possible please.

dgxhubbard
Posts: 42
Joined: Fri 14 Aug 2015 20:58

Re: Class definition mission

Post by dgxhubbard » Fri 14 Aug 2015 21:08

I forgot to add there are no errors or warnings and the model was validates. I tried doing explorer > tables/views right clicking on the table name and selecting "Create Class". This does not create the class either.

dgxhubbard
Posts: 42
Joined: Fri 14 Aug 2015 20:58

Re: Class definition mission

Post by dgxhubbard » Fri 14 Aug 2015 21:09

When I do a search for SecurityLinks I get this result:

Find all "SecurityLinks", Entire Model
GtModel.edml (Diagram1) (StorageEntity): SecurityLinks (GAGETRAK.SecurityLinks)
Matches found: 1 Matching items: 1 Total items searched: 3423

dgxhubbard
Posts: 42
Joined: Fri 14 Aug 2015 20:58

Re: Class definition mission

Post by dgxhubbard » Fri 14 Aug 2015 21:58

Is there any kind of log file to find out what happened during generation?

dgxhubbard
Posts: 42
Joined: Fri 14 Aug 2015 20:58

Re: Class definition mission

Post by dgxhubbard » Fri 14 Aug 2015 22:06

I viewed the table in question in Database explorer and right clicked on it then selected "Add To Model".
Still the class does not show up in Model Explorer classes. Is there some sort of limit on the number of classes. Is there someway to find out what is wrong here.

MariiaI
Devart Team
Posts: 1472
Joined: Mon 13 Feb 2012 08:17

Re: Class definition mission

Post by MariiaI » Mon 17 Aug 2015 11:09

Please specify the edition of Entity Developer you are using. If it is the Express one, then it is limited to 10 entities in the project: https://www.devart.com/entitydeveloper/editions.html
Actually, in this case you should receive a message indicating that you are using the Express edition with the limitations.

If it is not the case, please send us a test model and DDL scripts for the database tables, with which you are encountering this behaviour, and describe the exact steps to perform, so that we are able to reproduce this issue and investigate it in more details.

Post Reply