Model designer cant open in designmode

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
3dots
Posts: 3
Joined: Thu 05 Mar 2015 07:00

Model designer cant open in designmode

Post by 3dots » Thu 05 Mar 2015 07:03

Hi at all

I have a VisualStudio 2013 Professional.
The hbml Model file only open in xml view.

When i create a new hbml Model the designer is open, but reopening the designer not working.

please have any a sugestion for me ?

best regards

MariiaI
Devart Team
Posts: 1472
Joined: Mon 13 Feb 2012 08:17

Re: Model designer cant open in designmode

Post by MariiaI » Thu 05 Mar 2015 07:39

Please try right-clicking the model file (*.hbml) in Visual Studio and selecting "Open With..." from the shortcut menu. In the opened window select "Devart Entity Developer", click "Set as Default" and then "OK".

Please tell us if this helps.

3dots
Posts: 3
Joined: Thu 05 Mar 2015 07:00

Re: Model designer cant open in designmode

Post by 3dots » Thu 05 Mar 2015 08:36

Many thanks for this solution...

But... when i open the designer outside of visual studio i cant define the generated file in project -> folder... only on explorerpath

"EDIT"
I have found the solution... I have two entity developer items in the "open with" dialog...
Now i select the second one and then it works...
"EDIT"

MariiaI
Devart Team
Posts: 1472
Joined: Mon 13 Feb 2012 08:17

Re: Model designer cant open in designmode

Post by MariiaI » Thu 05 Mar 2015 10:25

3dots wrote:But... when i open the designer outside of visual studio i cant define the generated file in project -> folder... only on explorerpath
Please describe this issue in more details, e.g. specify the steps we should follow to reproduce the behaviour you are encountering, so that we are able to investigate it and find the solution for you.
3dots wrote:Now i select the second one and then it works...
Glad to see that this issue was resolved.

Post Reply