edmx wont generate class files after adding table

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
les_stockton
Posts: 1
Joined: Tue 14 Oct 2014 16:01

edmx wont generate class files after adding table

Post by les_stockton » Tue 14 Oct 2014 16:03

I am working on a large project with loads of tables in the data model (the edmx file). I recently added a couple of tables and everything was fine, but since that time something has happened that causes errors if I try to update model from the database and add a new table. No matter which table I try, I get loads of errors.

multiplicity errors in relationships, and many other errors, and none of the data model classes are generated. Even if I Transform All T4 Templates, it still wont generate any of the data classes.

I have tried pulling older versions of the edmx from source control, but it doesn't matter. I get the same errors and am in a stalemate.

Shalex
Site Admin
Posts: 8246
Joined: Thu 14 Aug 2008 12:44

Re: edmx wont generate class files after adding table

Post by Shalex » Tue 14 Oct 2014 16:35

1. Please migrate your model to Entity Developer (Devart Entity Model, *.edml) from EDM Designer (ADO.NET Entity Data Model, *.edmx).
Entity Developer allows only to import *.edmx but the output would be *.edml. Output can not be *.edmx because Entity Developer uses extra tags and attributes, additional features which are not supported by EDM Designer. Devart designer (*.edml) offers a wider range of functionality comparing to the standard designer: http://www.devart.com/entitydeveloper/ed-vs-edm.html.
Does usage of *.edml help to identify and fix the problem?

2. Tell us the name of the database server you are working with.

Post Reply