T4 Template Editor

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
quip85673456
Posts: 13
Joined: Mon 18 Apr 2011 16:37

T4 Template Editor

Post by quip85673456 » Mon 25 Aug 2014 19:50

Not sure where to post this.

Using the Devart T4 editor add-in for Visual Studio 2013.
I want to turn off the indenting and the auto-formatting.

I found the "T4 (Devart)" section in the Options menu.
I set the Tabs > Indenting option to "None" but it didn't help.

When I type a method and then a semi-colon, the editor indents the line:

Before:

Code: Select all

<# MyMethod() #>
After:

Code: Select all

<#    MyMethod(); #>

MariiaI
Devart Team
Posts: 1472
Joined: Mon 13 Feb 2012 08:17

Re: T4 Template Editor

Post by MariiaI » Wed 27 Aug 2014 10:31

quip85673456 wrote: I found the "T4 (Devart)" section in the Options menu.
I set the Tabs > Indenting option to "None" but it didn't help.
Please try changing the value of "Indent size" from 4 to, for example, 1 and tell us about the results.

quip85673456
Posts: 13
Joined: Mon 18 Apr 2011 16:37

Re: T4 Template Editor

Post by quip85673456 » Wed 27 Aug 2014 14:37

Changed tab size to 1:

Before:

Code: Select all

<#       KeyColumn("role_id, sub_role_id") #>

Code: Select all

<# KeyColumn("role_id, sub_role_id"); #>

MariiaI
Devart Team
Posts: 1472
Joined: Mon 13 Feb 2012 08:17

Re: T4 Template Editor

Post by MariiaI » Thu 28 Aug 2014 05:48

Please tell us whether this is what you expected to get or not.

quip85673456
Posts: 13
Joined: Mon 18 Apr 2011 16:37

Re: T4 Template Editor

Post by quip85673456 » Thu 28 Aug 2014 15:11

No it isn't what I would like.

I would like to disable formatting so that nothing is changed as I'm typing in the t4 script.

MariiaI
Devart Team
Posts: 1472
Joined: Mon 13 Feb 2012 08:17

Re: T4 Template Editor

Post by MariiaI » Fri 29 Aug 2014 08:57

We will investigate this issue and inform you about the results as soon as possible.

Post Reply