VS 2013 Update 2

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
peterharris
Posts: 13
Joined: Fri 03 Jan 2014 11:13

VS 2013 Update 2

Post by peterharris » Fri 16 May 2014 15:02

I installed Visual Studio 2013 Update 2 today. And since I have done so Entity Developer (I'm running version 5.7.357) returns an error in a .info file whenever I make a change to my LinqConnect context model. I am now not able to update my model.

I don't know whether it is just a coincidence or if installing the update has caused this error, but this is the message:

Code: Select all

'Custom tool 'DevartLinqToSqlGenerator' failed.
' - The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)
'
I hope you can help,

Many thanks,

Peter

MariiaI
Devart Team
Posts: 1472
Joined: Mon 13 Feb 2012 08:17

Re: VS 2013 Update 2

Post by MariiaI » Mon 19 May 2014 11:20

We have made tests with LinqConnect and Visual Studio 2013 (before installing Update 2 and after) and the error is not reproducible in our environment.

Please try performing the following:
- uninstall LinqConnect;
- clear the Program Files\Devart\dotConnect, Program Files\Devart\Entity Developer and Program Files\Common Files\Devart\dotConnect, Program Files\Common Files\Devart\Entity Developer folders;
- remove all Devart.* and policy.*.Devart.* files from the GAC;
- install LinqConnect.
Make sure that during uninstalling/installing all Visual Studio instances are closed.

If the error occurs again after reinstall, please specify the templates you are using to generate the model (i.e., whether it is one of default templates or a custom one).
And if possible, please send us the model with which you are encountering the error.

peterharris
Posts: 13
Joined: Fri 03 Jan 2014 11:13

Re: VS 2013 Update 2

Post by peterharris » Mon 19 May 2014 16:00

Thanks for looking into this.

I have tried uninstalling as you have suggested above, to no avail.
I am using the default LinqConnect template.

I have emailed the model to support@devart.com.


Many thanks,

Peter

MariiaI
Devart Team
Posts: 1472
Joined: Mon 13 Feb 2012 08:17

Re: VS 2013 Update 2

Post by MariiaI » Tue 20 May 2014 10:00

We have answered you by e-mail.

peterharris
Posts: 13
Joined: Fri 03 Jan 2014 11:13

Re: VS 2013 Update 2

Post by peterharris » Tue 20 May 2014 10:31

Thank you for your reply. It is all working again. I am very impressed with your timely response, it is very much appreciated.

Post Reply