Minor bug in Model Settings dialog regarding Extended Properties

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
billster6809
Posts: 29
Joined: Mon 27 Jan 2014 21:08

Minor bug in Model Settings dialog regarding Extended Properties

Post by billster6809 » Tue 08 Apr 2014 23:33

This is from within the Visual Studio editor, not the stand-alone. I do not see this with the stand-alone program.
Version: 5.7.321

Using the Model Settings dialog to add Extended Properties, I have noticed when creating Class, Property and RelationProperty properties, the first time I click "Add", nothing shows up. I have to exist the dialog and re-enter to then see the newly added "Property1".

If, instead of existing, I click "Add" again, I see "Property2". To see "Property1", I again have to exit and re-enter.

MariiaI
Devart Team
Posts: 1472
Joined: Mon 13 Feb 2012 08:17

Re: Minor bug in Model Settings dialog regarding Extended Properties

Post by MariiaI » Fri 11 Apr 2014 05:20

We couldn't reproduce this issue in our environment.
Please specify the following information:
- the version and edition of Visual Studio you are working with;
- the exact step-by-step scenario we should perform to reproduce this behaviour, etc.

You can also try reinstalling Entity Developer:
- uninstall Entity Developer and other Devart products, which can use common assemblies (if there are any);
- clear the Program Files\Devart\dotConnect, Program Files\Devart\Entity Developer and Program Files\Common Files\Devart\dotConnect, Program Files\Common Files\Devart\Entity Developer folders;
- remove all Devart.* and policy.*.Devart.* files from the GAC;
- install Entity Developer and other Devart products, if necessary.
Make sure, that during uninstalling/installing all Visual Studio instances are closed.

Looking forward to your reply.

billster6809
Posts: 29
Joined: Mon 27 Jan 2014 21:08

Re: Minor bug in Model Settings dialog regarding Extended Properties

Post by billster6809 » Mon 07 Jul 2014 16:11

Forgot to mention that I no longer see this problem either.

Post Reply