Newbie issue please help

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
simonmay
Posts: 1
Joined: Fri 04 Oct 2013 16:44

Newbie issue please help

Post by simonmay » Fri 04 Oct 2013 17:13

I have just downloaded a eval copy of Entity Developer as I believe that this could provide serious assistance on a current project.

I installed and pointed the tool at the database and attempted to build the model from database. everything worked well apart from one issue. It complained that one of my tables did not have a primary key. I created the key in the database and regenerated the model. Now I get 28 errors, all similar. I include one example below

Properties referred by the Principal Role mwcSchemaUpdateSourceType must be exactly identical to the key of the EntityType SnFleetEntityModel.Store.mwcSchemaUpdateSourceType referred to by the Principal Role in the relationship constraint for Relationship SnFleetEntityModel.Store.mwcSchemaUpdate_SchUpdSrcTy_FK. Make sure all the key properties are specified in the Principal Role. SnEntityModel.edml


I find it difficult to believe that the inclusion of a primary key in a totally unrelated table caused these errors rather I suspect that perhaps these were not reported the first time because the the tool stopped reporting errors on finding the primary key issue. (I only mentioned it so you have the full facts)

I have examined the .edml file and cannot find any basis for these reported errors. I am reasonably familiar with Entity Framework and the structure and content of .edmsx and consequently .edml files

This database schema belongs to a successful commercial product, it has over 500 tables in it.

Perhaps someone might be kind enough to give me a steer on how to attack this problem. Everything else about the product I like but cant really see us buying it until I can resolve or at least understand this issue.

Thank you in anticipation of a quick response.

Kind regards

Simon

Shalex
Site Admin
Posts: 8247
Joined: Thu 14 Aug 2008 12:44

Re: Newbie issue please help

Post by Shalex » Mon 07 Oct 2013 12:07

Please try to localize the issue with a couple of related classes and send us a test model with the corresponding DDL script if possible.

Otherwise, give us a complete model which generates the errors. We will analyse it and notify you about the result.

Shalex
Site Admin
Posts: 8247
Joined: Thu 14 Aug 2008 12:44

Re: Newbie issue please help

Post by Shalex » Thu 10 Oct 2013 08:28

Also try using the latest (5.5.196) build of Entity Developer because the issue may be already fixed.

Post Reply