Parameter order not changing when updating model from DB... :(

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
HSNMatt
Posts: 18
Joined: Thu 18 Apr 2013 15:30
Location: St Petersburg, FL

Parameter order not changing when updating model from DB... :(

Post by HSNMatt » Mon 10 Jun 2013 20:47

I am using Entity Developer 5.5.120 alongside DotConnect Oracle 7.7.257.0.

I have been having an issue where my stored procedures are not updating correctly.

1) I had a stored procedure where a few fields were added in the middle of the procedure call. I had Entity Developer do an update from the DB, and it recognized that these fields had been moved around (order changed) and that the new fields had been added. When I completed the update, the new fields were just added at the end, and none of the parameters were moved. I had to manually perform this task.

2) I had a stored procedure where I had to remove a few fields. On doing a update (update model from DB), it recognized that these fields had been removed from the procedure, but when I completed the update the parameters were still there in the storage object. I had to manually remove them.

I'm not sure if this falls under Entity Developer or dotConnect Oracle but I'm pretty sure it falls under Entity Developer.

I'm using VS2012 as my development environment on a Windows 7 machine.

Please help! Data integrity is a MUST for this application, and this issue could cause a loss of data integrity...

Shalex
Site Admin
Posts: 8245
Joined: Thu 14 Aug 2008 12:44

Re: Parameter order not changing when updating model from DB... :(

Post by Shalex » Wed 12 Jun 2013 10:10

HSNMatt wrote:1) I had a stored procedure where a few fields were added in the middle of the procedure call. I had Entity Developer do an update from the DB, and it recognized that these fields had been moved around (order changed) and that the new fields had been added. When I completed the update, the new fields were just added at the end, and none of the parameters were moved. I had to manually perform this task.
We have reproduced the issue and are investigating it.
HSNMatt wrote:2) I had a stored procedure where I had to remove a few fields. On doing a update (update model from DB), it recognized that these fields had been removed from the procedure, but when I completed the update the parameters were still there in the storage object. I had to manually remove them.
We cannot reproduce the problem. Please send us a test model with the DDL script of your stored procedure and specify the steps for reproducing.

HSNMatt
Posts: 18
Joined: Thu 18 Apr 2013 15:30
Location: St Petersburg, FL

Re: Parameter order not changing when updating model from DB... :(

Post by HSNMatt » Wed 12 Jun 2013 16:20

We cannot reproduce the problem. Please send us a test model with the DDL script of your stored procedure and specify the steps for reproducing.
I am emailing with Aleksandr from your support team about this issue.

Shalex
Site Admin
Posts: 8245
Joined: Thu 14 Aug 2008 12:44

Re: Parameter order not changing when updating model from DB... :(

Post by Shalex » Wed 19 Jun 2013 09:47

  • The bug with ordering parameters of a method when Update From Database Wizard adds/removes parameters to the method signature is fixed
  • The bug with removing stored procedure parameters in SSDL when using Update From Database Wizard is fixed
We will post here when the corresponding build of dotConnect for Oracle is available for download.

Shalex
Site Admin
Posts: 8245
Joined: Thu 14 Aug 2008 12:44

Re: Parameter order not changing when updating model from DB... :(

Post by Shalex » Thu 20 Jun 2013 16:02

New build of dotConnect for Oracle 7.7.267 is available for download now!
It can be downloaded from http://www.devart.com/dotconnect/oracle/download.html (trial version) or from Registered Users' Area (for users with active subscription only).
For more information, please refer to http://forums.devart.com/viewtopic.php?f=1&t=27386.

HSNMatt
Posts: 18
Joined: Thu 18 Apr 2013 15:30
Location: St Petersburg, FL

Re: Parameter order not changing when updating model from DB... :(

Post by HSNMatt » Fri 21 Jun 2013 14:42

Shalex wrote:New build of dotConnect for Oracle 7.7.267 is available for download now!
It can be downloaded from http://www.devart.com/dotconnect/oracle/download.html (trial version) or from Registered Users' Area (for users with active subscription only).
For more information, please refer to http://forums.devart.com/viewtopic.php?f=1&t=27386.
Seems to be working now. Thanks.

Post Reply