Some of my Property Names are getting singularized, how to prevent?

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
EdB
Posts: 91
Joined: Mon 15 Oct 2012 09:24

Some of my Property Names are getting singularized, how to prevent?

Post by EdB » Mon 03 Jun 2013 09:36

Hi,

I have a number of plural looking property names like "Circumstances", "Terms" etc which ED is converting to "Circumstance" and "Term". This happens on the Storage Entity. The DB is correct and the class is correct, but I obviously then get a runtime error as it cannot find a column called "Circumstance".

How can I prevent ED altering these property names?

Many thanks.

Shalex
Site Admin
Posts: 8248
Joined: Thu 14 Aug 2008 12:44

Re: Some of my Property Names are getting singularized, how to prevent?

Post by Shalex » Tue 04 Jun 2013 07:03

Right click on the diagram > Model Settings > Synchronization > Database Naming and check your current naming rules. These settings are applied when Model Settings > Synchronization > Mapping > "Enable automatic synchronization of storage part and mapping of the model with its conceptual part" is selected.

EdB
Posts: 91
Joined: Mon 15 Oct 2012 09:24

Re: Some of my Property Names are getting singularized, how to prevent?

Post by EdB » Tue 04 Jun 2013 08:17

Thanks.

Post Reply