T4Editor and Entity Developer together?

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
sanyock
Posts: 3
Joined: Fri 19 Apr 2013 07:19

T4Editor and Entity Developer together?

Post by sanyock » Sun 28 Apr 2013 11:09

Hello,

T4Editor does not appear in Visual Studio 2008 STD EN, can you please
suggest a solution, URLs with suggestions, etc.

Does Entity Developer Express contain T4 feature too?
Can it be used from Visual Studio?

Thank you,
Alexander

StanislavK
Devart Team
Posts: 1710
Joined: Thu 03 Dec 2009 10:48

Re: T4Editor and Entity Developer together?

Post by StanislavK » Mon 29 Apr 2013 11:42

Please ensure that you used the proper installation of T4 Editor: it has a separated installation package for each Visual Studio version (2008, 2010, and 2012). You can download the one for Visual Studio 2008 from
http://www.devart.com/t4-editor/download.html

If you are encountering any problems with this, please describe them in more details. For example, saying that T4 Editor doesn't work under VS 2008, do you mean that there is no T4 Editor item in the VS menu, or, e.g., that you are getting an exception when working with a template?

As for Entity Developer Express, it does not provide the template editing functionality:
http://www.devart.com/entitydeveloper/editions.html

sanyock
Posts: 3
Joined: Fri 19 Apr 2013 07:19

Re: T4Editor and Entity Developer together?

Post by sanyock » Mon 29 Apr 2013 11:49

StanislavK wrote:For example, saying that T4 Editor doesn't work under VS 2008, do you mean that there is no T4 Editor item in the VS menu
Tried for VS2008:
http://www.devart.com/t4-editor/t4editor.exe

It does not appear anywhere including menu too

How can I find its config and verify?

On the other hand Entity Developer Express appeared fine in VS menu.
Then I tried a trial version of Entity Developer to see more entities, it worked fine after fist execution as a standalone, but it hanged and did display its screen on any further run.
I tried to restart Windows, it did not help.

StanislavK
Devart Team
Posts: 1710
Joined: Thu 03 Dec 2009 10:48

Re: T4Editor and Entity Developer together?

Post by StanislavK » Tue 30 Apr 2013 11:41

With Visual Studio 2010 and 2012, T4 Editor is added as an extension package. As Visual Studio 2008 does not support extension packages, T4 Editor is just installed as one of studio's file editors. To ensure T4 Editor was installed, you can do one of the following:
1) check the 'Devart T4 Editor' item in the Start menu;
2) use the 'Open With' menu item on a template file in Visual Studio; if T4 Editor is installed, there should be the 'Devart Template Editor' option available.

As for the problem with Entity Developer, please try re-installing the Entity Developer trial. If the problem persists, please specify it in more details; e.g., please specify the following:
- whether Entity Developer hangs in both Visual Studio and standalone modes;
- what exact screen it is showing;
- whether this problem occurs only when trying to open an existing model or when creating a new one as well.

sanyock
Posts: 3
Joined: Fri 19 Apr 2013 07:19

Re: T4Editor and Entity Developer together?

Post by sanyock » Tue 30 Apr 2013 12:48

StanislavK wrote:As for the problem with Entity Developer, please try re-installing the Entity Developer trial. If the problem persists, please specify it in more details; e.g., please specify the following:
- whether Entity Developer hangs in both Visual Studio and standalone modes;
- what exact screen it is showing;
- whether this problem occurs only when trying to open an existing model or when creating a new one as well.
I did not use trial version in VS and did not plan to use paid one when was going to purchase, only standalone mode

No any screen at all

The problem of not seen a GUI appears before triyng to create or open, as long as there is no any GUI elements to create or open anything

Shalex
Site Admin
Posts: 8245
Joined: Thu 14 Aug 2008 12:44

Re: T4Editor and Entity Developer together?

Post by Shalex » Mon 20 May 2013 07:34

Please reinstall Entity Developer in the following way:
1) uninstall Entity Developer and other Devart ADO.NET products
2) make sure that there are no Devart.* and policy.*.Devart.* files in the following folders:
* \Program Files (x86)\Microsoft Visual Studio *\Common7\IDE\PrivateAssemblies\Devart\
* GAC 2.0 (\Windows\assembly\) and GAC 4.0 (\Windows\Microsoft.NET\assembly\)
* \Program Files (x86)\Devart\
* \Program Files (x86)\Common Files\Devart\
* \Documents and Settings\All Users\Devart\EntityDeveloper\ (clear the folder)
* \Documents and Settings\All Users\Devart\dotConnect\ (clear the folder)
3) install Entity Developer Express with the following command line parameter: entitydeveloperfree.exe /log=Install.log . The Install.log file will be created in the folder where the installation file is located. Please send us this file.
sanyock wrote:No any screen at all

The problem of not seen a GUI appears before triyng to create or open, as long as there is no any GUI elements to create or open anything
Please run \Program Files (x86)\Devart\EntityDeveloper\EntityDeveloper.exe via the "As administrator" menu option. If still nothing happens, open Event Viewer and check Application Logs: are there any errors about Entity Developer?

Notify us about the results.

Post Reply