Unable to refresh entity models from Oracle

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
HSNMatt
Posts: 18
Joined: Thu 18 Apr 2013 15:30
Location: St Petersburg, FL

Unable to refresh entity models from Oracle

Post by HSNMatt » Thu 18 Apr 2013 16:11

Hello,

Recently we upgraded our version of dotConnect to 7.7 (build 7.7.217.0) and EntityDeveloper to 5.5.80. Since the update we have been seeing a strange behavior when doing a model refresh.

First, we'll see this error message:
Image

And then the "Choose actions" box comes up completely missing one schema, and not loading in any metadata for the other:
Image

The work-around that I've found is to recreate the model completely for any small change. This is not acceptable seeing as my model consists of 1 table and 22 stored procedures that span between 2 schemas. dotConnect 7.6 had no problems with this, and I had to refresh my model many times.

Is this a known bug? Has there been a fix to this yet?

Thanks!

Shalex
Site Admin
Posts: 8241
Joined: Thu 14 Aug 2008 12:44

Re: Unable to refresh entity models from Oracle

Post by Shalex » Fri 19 Apr 2013 08:49

Could you please send us your model so that we can reproduce the issue in our environment?

HSNMatt
Posts: 18
Joined: Thu 18 Apr 2013 15:30
Location: St Petersburg, FL

Re: Unable to refresh entity models from Oracle

Post by HSNMatt » Fri 19 Apr 2013 15:06

I sent it to devArt support a few moments ago. I don't know how to upload files to the forums yet.

Shalex
Site Admin
Posts: 8241
Joined: Thu 14 Aug 2008 12:44

Re: Unable to refresh entity models from Oracle

Post by Shalex » Tue 23 Apr 2013 14:54

The problem is fixed in the new (5.5.89) build of Entity Developer.
It can be downloaded from http://www.devart.com/entitydeveloper/download.html (trial version) or from Registered Users' Area (for users with active subscription only).
For more information, please refer to http://forums.devart.com/viewtopic.php?f=32&t=26933.

troyb30
Posts: 5
Joined: Fri 10 May 2013 10:54

Re: Unable to refresh entity models from Oracle

Post by troyb30 » Fri 10 May 2013 10:57

I am using Entity Developer 5.5.89 and have the same problem where I am unable to refresh the data model.

Is there any logging available to show further details?

bdeluard
Posts: 6
Joined: Sun 19 Feb 2012 23:26

Re: Unable to refresh entity models from Oracle

Post by bdeluard » Fri 10 May 2013 14:19

Hello,

I'm using 5.5.89 release, and I also have the same bug with a SQL/Server database, where the only difference is a new stored proc to create a complex type...

Our dev process is blocked for that problem.

have you idea about resolution or temporary workaround?

Thanks in advance,

Bruno

ps: I found a workaround : I executed partially the update database from model, which does not show me any change, and cancel it. After that, executing the update model from database wizard show me correctly the changes...
ps2: not so good... unable to save the model after that : vs2012 is locked

HSNMatt
Posts: 18
Joined: Thu 18 Apr 2013 15:30
Location: St Petersburg, FL

Re: Unable to refresh entity models from Oracle

Post by HSNMatt » Mon 13 May 2013 16:02

A workaround that I found... When you execute the "Update model from DB" command and it gives the option to regenerate the model completely, use that. It's not a good workaround though because you will have to completely rebuild the model :(

troyb30
Posts: 5
Joined: Fri 10 May 2013 10:54

Re: Unable to refresh entity models from Oracle

Post by troyb30 » Tue 14 May 2013 07:23

Unfortunately that is not a workable solution, as I have alot of tables and alot of custom relationships. Recreating all the tables will take a few hours.

HSNMatt
Posts: 18
Joined: Thu 18 Apr 2013 15:30
Location: St Petersburg, FL

Re: Unable to refresh entity models from Oracle

Post by HSNMatt » Tue 14 May 2013 16:30

troyb30 wrote:Unfortunately that is not a workable solution, as I have alot of tables and alot of custom relationships. Recreating all the tables will take a few hours.
Yeah man, I feel you there. It's painful.

The update fixed it for me I think. I haven't had that issue lately. The only issue I have sometimes is when a stored procedure changes, I have to remove all traces of it (including the storage item) and re-add it. This is only if the parameters changed, but if the returned dataset changes I can just delete the complex type and method and recreate them.

Shalex
Site Admin
Posts: 8241
Joined: Thu 14 Aug 2008 12:44

Re: Unable to refresh entity models from Oracle

Post by Shalex » Thu 16 May 2013 11:27

troyb30 wrote:I am using Entity Developer 5.5.89 and have the same problem where I am unable to refresh the data model.
Thank you for your report. We have asked you for more details by e-mail. Looking forward to your reply.
HSNMatt wrote:The only issue I have sometimes is when a stored procedure changes, I have to remove all traces of it (including the storage item) and re-add it. This is only if the parameters changed, but if the returned dataset changes I can just delete the complex type and method and recreate them.
Thank you for your feedback. We have asked you for details by e-mail. Please give us more information for reproducing.
bdeluard wrote:I'm using 5.5.89 release, and I also have the same bug with a SQL/Server database, where the only difference is a new stored proc to create a complex type...
Thank you for the report. If the problem is caused by only one stored procedure, please specify your ORM framework and send us the DDL of this procedure and related database objects.
If this is not enough for reproducing, give us the following information:
1) a test model
2) the DDL script of a database schema you are updating your model from
3) the version of your SQL Server
Looking forward to your reply.

troyb30
Posts: 5
Joined: Fri 10 May 2013 10:54

Re: Unable to refresh entity models from Oracle

Post by troyb30 » Fri 24 May 2013 13:45

Is there an ETA on when this is going to be fixed? its been over a week since this was reported.

HSNMatt
Posts: 18
Joined: Thu 18 Apr 2013 15:30
Location: St Petersburg, FL

Re: Unable to refresh entity models from Oracle

Post by HSNMatt » Fri 24 May 2013 14:15

troyb30 wrote:Is there an ETA on when this is going to be fixed? its been over a week since this was reported.
Since the update, I have had no more problems with this.

troyb30
Posts: 5
Joined: Fri 10 May 2013 10:54

Re: Unable to refresh entity models from Oracle

Post by troyb30 » Fri 24 May 2013 15:06

After the last release I could then see the tables and procedures, but most of the tables were outside of the tables & views group.

E.g.

Tables & views
- table 1
- table 2
- table 3

Procedures & functions
- proc 1
- proc 2
- func 1

Packages
- Package 1
- Package 2
- Package 3

- Table 4
- Table 5
- Table 6
- Table 7

Shalex
Site Admin
Posts: 8241
Joined: Thu 14 Aug 2008 12:44

Re: Unable to refresh entity models from Oracle

Post by Shalex » Mon 27 May 2013 07:53

troyb30 wrote:After the last release I could then see the tables and procedures, but most of the tables were outside of the tables & views group.
Thank you for your report. We have reproduced and fixed the problem. We will post here when the next public build of Entity Developer is available for download.

Shalex
Site Admin
Posts: 8241
Joined: Thu 14 Aug 2008 12:44

Re: Unable to refresh entity models from Oracle

Post by Shalex » Thu 30 May 2013 14:22

New build of Entity Developer 5.5.115 is available for download now!
It can be downloaded from http://www.devart.com/entitydeveloper/download.html (trial version) or from Registered Users' Area (for users with active subscription only).
For more information, please refer to http://forums.devart.com/viewtopic.php?f=32&t=27232.

Post Reply