Search not working in VS2012

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
andrecarlucci
Posts: 4
Joined: Wed 13 Mar 2013 18:41

Search not working in VS2012

Post by andrecarlucci » Thu 14 Mar 2013 15:00

Hi guys,

String search is not working when editing templates in VS2012. It finds only the first occurrence of the searched string.

Using Entity Developer NHibernate 5.0.66

Also, it would be really nice to be able to use already existing enums of my project instead of having to recreate then in the model explorer.

Cheers,

André Carlucci

Shalex
Site Admin
Posts: 8245
Joined: Thu 14 Aug 2008 12:44

Re: Search not working in VS2012

Post by Shalex » Fri 15 Mar 2013 16:56

andrecarlucci wrote:String search is not working when editing templates in VS2012. It finds only the first occurrence of the searched string.
We have reproduced the problem and will notify you when it is fixed.
andrecarlucci wrote:it would be really nice to be able to use already existing enums of my project instead of having to recreate then in the model explorer
Starting from the 5.1 version of Entity Developer, the IsExternal property of Enum will be implemented. So, when IsExternal=True, it will be possible to have the enum in the code, and you will need only to specify its name and namespace in model's enum (creating enum members will not be necessary).

Current build of Entity Developer: open Property Editor, select Custom type in the Type drop-down, and specify the full type name of your external enum: "MyNamespace.MyType, MyAssembly" (without quotes).

andrecarlucci
Posts: 4
Joined: Wed 13 Mar 2013 18:41

Re: Search not working in VS2012

Post by andrecarlucci » Fri 15 Mar 2013 19:52

Great! Thanks a lot :)

Shalex
Site Admin
Posts: 8245
Joined: Thu 14 Aug 2008 12:44

Re: Search not working in VS2012

Post by Shalex » Fri 05 Apr 2013 12:05

New version of Entity Developer 5.5 is released!
It can be downloaded from http://www.devart.com/entitydeveloper/download.html (trial version) or from Registered Users' Area (for users with active subscription only).
For more information, please refer to http://forums.devart.com/viewtopic.php?f=32&t=26309.

Shalex
Site Admin
Posts: 8245
Joined: Thu 14 Aug 2008 12:44

Re: Search not working in VS2012

Post by Shalex » Fri 30 Mar 2018 16:49

The bug with the Find Next functionality of T4 Editor embedded into Visual Studio is fixed: viewtopic.php?f=32&t=36964.

Post Reply