Model Explorer treeview looses state information

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
ODN
Posts: 10
Joined: Mon 14 Jan 2013 05:25

Model Explorer treeview looses state information

Post by ODN » Tue 05 Feb 2013 09:30

Switching from either template or diagram view to any other not entity developer related view, the model explorer treeview will loose its treeview node state information after switching back.
Every treenode that has been expanded (like Model->Classes->Class->Property or Templates->Template) before is in collapsed state when the model explorer gets re-displayed if you switch back to either template editor or diagram editor.
This is really annoying, as you have to manually re-expand all the nodes you have actively been working on all the time! I would consider this to be a bug. Could you please have a look at this. Thanks in advance

Kind regards,
Oliver
VS 2012 / Win7 X64

Helen
Devart Team
Posts: 127
Joined: Wed 07 Sep 2011 11:54

Re: Model Explorer treeview looses state information

Post by Helen » Tue 05 Feb 2013 14:21

Thanks for your remark.

We will consider the possibility of changing the behavior of tree nodes in the Model Explorer you have described.
We will inform you as soon as we get any results.

ODN
Posts: 10
Joined: Mon 14 Jan 2013 05:25

Re: Model Explorer treeview looses state information

Post by ODN » Mon 06 May 2013 02:50

Any news on this issue?? This behaviour is still very annoying.

Helen
Devart Team
Posts: 127
Joined: Wed 07 Sep 2011 11:54

Re: Model Explorer treeview looses state information

Post by Helen » Tue 07 May 2013 07:45

Implementation of the possibility to change the behavior of tree nodes in Model Explorer is on our roadmap. But we cannot tell any timeframe at the moment.

Post Reply