Relations layouting

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
Alexey Zimarev
Posts: 2
Joined: Tue 15 May 2012 13:51

Relations layouting

Post by Alexey Zimarev » Tue 15 May 2012 14:05

Is there any setting that I can set to prevent relations to cross entities? Entity Framework designer and some other visual tools done it nicely but in DevArt I just see a grid of lines across entities.

Image

Helen
Devart Team
Posts: 127
Joined: Wed 07 Sep 2011 11:54

Re: Relations layouting

Post by Helen » Wed 16 May 2012 08:28

Have you tried to make a Layout Diagram via the diagram context menu item having the same name ?

We are currently investigating this issue for models having lots of associations.

Alexey Zimarev
Posts: 2
Joined: Tue 15 May 2012 13:51

Re: Relations layouting

Post by Alexey Zimarev » Wed 16 May 2012 09:48

The issue with shapes overlapping relations is not only for large models. I tried on the same database with with an empty model, added couple of tables to the model, there are just a few relations there. But when I move a shape and drop it to the place where relations are already visualized as lines, these lines are not rearranged as for example in EDM designer or MindScape model designer, check the attachment
Image

Helen
Devart Team
Posts: 127
Joined: Wed 07 Sep 2011 11:54

Re: Relations layouting

Post by Helen » Wed 16 May 2012 12:42

Alexey Zimarev wrote:But when I move a shape and drop it to the place where relations are already visualized as lines, these lines are not rearranged as for example in EDM designer or MindScape model designer
To make relations rebuild for your current diagram, select the Options item in the diargam context menu. Then in the General page deselect the Preserve Routing check-box.
If you need to preserve routing of relation links on the diagram, then keep this check-box selected.

If you don't want Preserve Routing to be applied to your new diagrams and models,deselect this check-box at the general level. If you work with the standalone application, in the application's main menu, select Tools and then select Options. Expand the Diagram node and, under it, select General. Uncheck the Preserve Routing check-box.
When working with Visual Studio use the menu Tools->Entity Developer->Options.

Please inform us whether this information was helpful for you.

Post Reply