Custom-made template doesn't work after upgrade

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
Posts: 39
Joined: Thu 13 Aug 2009 21:22

Custom-made template doesn't work after upgrade

Post by afva » Mon 19 Dec 2011 14:08


We just upgraded our dotConnect/EntityDeveloper to newest version.
If I generate my Dataset (lqml) again, I get an error in the .info-file:
"Enabled templates are not specified."

My custom-made template doesn't work anymore.
I made my own template to check for stringLength; in the linqConnectProperties I see that you also added some validation-rules (Validate Max Length).
1. First I like to know how I can make my custom-template to work again;
2. How can I make use of your validation-rules?

Thank you,

Devart Team
Posts: 1710
Joined: Thu 03 Dec 2009 10:48

Post by StanislavK » Wed 21 Dec 2011 16:35

1. To ensure that your custom template is used, please perform the following:
- check whether it is available in the Templates node of the 'Model Explorer' tool window;
- if it is, open the Properties tool window for this template and set its 'Enabled' property to true;
- otherwise, add it to the model via the 'Add Template' dialog: select the 'Add Template' item of the 'Templates' context menu, then select the Custom -> 'Find Existing' option, and find your template on the disk. After that, perform the second step.

We've improved managing the templates in new versions of Entity Developer. For the detailed information on the capabilities of the latest version, please refer to the 'Common Concepts' -> 'Working with Templates' section of the Entity Developer documentation.

2. To enable the options like 'Validate Max Length', it is necessary to enable a validation framework (see the 'Validation Framework' property of your template), e.g., DataAnnotations: ... tions.aspx
In this case, the DataAnnotations attributes will be added to the generated entity classes.

Feel free to contact us if anything is unclear.

Post Reply