[BUG] IsFlag property for Enums (v4.1.41)

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
r.heuschkel@ibitech.com
Posts: 14
Joined: Mon 22 Aug 2011 15:44

[BUG] IsFlag property for Enums (v4.1.41)

Post by r.heuschkel@ibitech.com » Thu 22 Sep 2011 15:57

When you set the IsFlag property for Enum-Types in the newest Version of ED, it stores in the .edml file. The problem is, that "True" is not the valid boolean string value according to the XML-Schema. It should be "true" instead.

This results in always getting the following error when running the code generation: "Custom tool error: The 'IsFlags' attribute is invalid - The value 'True' is invalid according to its datatype 'http://www.w3.org/2001/XMLSchema:boolean' - The string 'True' is not a valid Boolean value."

StanislavK
Devart Team
Posts: 1710
Joined: Thu 03 Dec 2009 10:48

Post by StanislavK » Mon 26 Sep 2011 13:33

Thank you for the report, we have reproduced the issue. We will inform you when it is fixed.

As a workaround, you can fix the 'IsFlags' property manually.

StanislavK
Devart Team
Posts: 1710
Joined: Thu 03 Dec 2009 10:48

Post by StanislavK » Wed 16 Nov 2011 18:11

We have fixed the issue. The fix is available in the latest 4.1.71 build of Entity Developer. The new build can be downloaded from
http://www.devart.com/entitydeveloper/download.html
(the trial and free versions) or from Registered Users' Area (provided that you have an active subscription).

For the detailed information about the fixes and improvements available in Entity Developer 4.1.71, please refer to
http://www.devart.com/forums/viewtopic.php?t=22541

Post Reply