[BUG] Attribute parameter generation in VB.NET (v4.0.30)

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
r.heuschkel@ibitech.com
Posts: 14
Joined: Mon 22 Aug 2011 15:44

[BUG] Attribute parameter generation in VB.NET (v4.0.30)

Post by r.heuschkel@ibitech.com » Mon 22 Aug 2011 15:55

The code generation for attribute parameters creates incorrect code for Visual Basic:

Code: Select all

 _
Public Overridable Property ID() As String
As you can see, it tries to use '=' to access a parameter by name, but the correct way to do this in VB is the ':=' operator. So the corrected code looks like that:

Code: Select all

 _
Public Overridable Property ID() As String

StanislavK
Devart Team
Posts: 1710
Joined: Thu 03 Dec 2009 10:48

Post by StanislavK » Wed 24 Aug 2011 08:48

Thank you for the report, we have reproduced the problem. We will fix it and inform you when the corresponding build is available.

Helen
Devart Team
Posts: 127
Joined: Wed 07 Sep 2011 11:54

Post by Helen » Wed 07 Sep 2011 12:13

We have released the new 4.1.41 version of Entity Developer, in which code generation is fixed for attribute parameters when a Visual Basic template is used.

The new build can be downloaded from http://www.devart.com/entitydeveloper/download.html (the trial version only) or from Registered Users' Area (for users with active subscription only): http://secure.devart.com/

For more information about the fixes available in the new build, please refer to http://www.devart.com/forums/viewtopic.php?t=21949

Post Reply