Entity Developer fails to load in Visual Studio 2008

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
mepolsen
Posts: 14
Joined: Mon 25 Oct 2010 19:14

Entity Developer fails to load in Visual Studio 2008

Post by mepolsen » Thu 28 Oct 2010 15:23

I have dotConnect installed for MySQL and SQLite installed on the same machine and Entity Developer fails to load in Visual Studio 2008. Below, is a copy of the error message that is generated:

=========================
General
=========================
Application: Microsoft Visual Studio 2008
Product: Entity Developer
Product Locale: English
Assembly: EntityDeveloper, Version=2.80.165.0, Culture=neutral, PublicKeyToken=09af7300eec23701
C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\PrivateAssemblies\Devart\EntityDeveloper.exe
Global cache: False
Framework: 2.0.50727.3615

=========================
Exception Information
=========================
Message: The type initializer for 'EntityDeveloper.NetShell.EntityDeveloperModule' threw an exception.
Source: mscorlib
TargetSite: Void _RunClassConstructor(IntPtr)
HelpLink:
Type: System.TypeInitializationException
Stack:
at System.Runtime.CompilerServices.RuntimeHelpers._RunClassConstructor(IntPtr type)
at System.Runtime.CompilerServices.RuntimeHelpers.RunClassConstructor(RuntimeTypeHandle type)
at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
at Devart.Shell.ModuleManager.LoadModuleInstance(ModuleEntry entry)

Message: GenericArguments[0], 'EntityDeveloper.d7', on 'EntityDeveloper.NetShell.EntityDeveloperModule+ToolWindowCreatableControl`1[TToolWindowControl]' violates the constraint of type parameter 'TToolWindowControl'.
Source: EntityDeveloper
TargetSite: Void .cctor()
HelpLink:
Type: System.TypeLoadException
Stack:
at EntityDeveloper.NetShell.EntityDeveloperModule..cctor()

I have reinstalled dotConnect with no luck. I have the same installations on another machine and Entity Developer works without any problems.

Thanks

AndreyR
Devart Team
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Post by AndreyR » Fri 29 Oct 2010 16:02

Do you have dbForge for MySQL or OraDeveloper Tools installed?

mepolsen
Posts: 14
Joined: Mon 25 Oct 2010 19:14

Post by mepolsen » Fri 29 Oct 2010 16:07

Yes, I have dbForge 3.50.331 for MySQL installed.

AndreyR
Devart Team
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Post by AndreyR » Mon 01 Nov 2010 14:15

Could you please specify the full versions of both dotConnect for MySQL and dotConnect for SQLite?

Post Reply