Entity Developer 2.80.136 - crash on open model

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
Alladin
Posts: 149
Joined: Mon 27 Nov 2006 16:18
Contact:

Entity Developer 2.80.136 - crash on open model

Post by Alladin » Tue 13 Jul 2010 12:08

Hi there,

The most hated bugs are those, which are new and coming with supposed-to-be bug-fix release. Just upgraded with a fresh version.

My model cannot be open with the new release, because ED crashes on open with StackOverflow exception.

I tried to remove all associations, which then allows me to open the model. But again, after reimplementing the same associations again, ED cannot open its own file.

Here is my model, for those who interested:

Code: Select all



  
  
    
      
      
      
      
      
      
      
      
      
      
      
      
      
      
      
      
      
      
      
    
  
  
    
      
      
      
      
      
      
      
      
    
  
  
    
      
      
      
      
      
      
      
      
      
      
      
      
      
      
    
  
  
    
      
      
      
      
      
      
      
      
      
      
    
  
  
    
      
      
      
      
      
      
      
      
      
      
      
      
      
      
      
      
      
      
      
      
      
      
    
  
  
    
  
  
    
  

Once again I question myself whether DevArt does regression tests BEFORE releasing a new version of their products.

AndreyR
Devart Team
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Post by AndreyR » Tue 13 Jul 2010 15:48

Thank you for the model, we have reproduced the error and are investigating it.
I will post here about the results of our investigation.

Alladin
Posts: 149
Joined: Mon 27 Nov 2006 16:18
Contact:

Post by Alladin » Wed 14 Jul 2010 10:27

There are also two classes NewPortfolioChangeset and EditPortfolioChangeset, which have to be derived from Changeset class, but since I cannot use Guid as discriminator column in ED, they are useless :(

AndreyR
Devart Team
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Post by AndreyR » Wed 14 Jul 2010 10:55

Our investigation regarding the ED and VS crash is in progress. As for the Guid problem, I have replied you here.

AndreyR
Devart Team
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Post by AndreyR » Tue 10 Aug 2010 09:33

The problem is fixed. Follow the announcements at our forum for the fixed build timeframe.

Post Reply