Problem with 'unsigned' columns

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
DarkCamper
Posts: 13
Joined: Wed 18 Mar 2015 17:31

Problem with 'unsigned' columns

Post by DarkCamper » Fri 18 Oct 2019 12:23

Hi!
I'm have some trouble creating a db-first NHibernate model when some table contains an unsigned int column (MySQL 5.1 or MariaDB 10 + Entity Developer 6.5.823)

The generated class has correct type (UInt32, after configuring it in 'Server Options/MySQL') but the associated column has sql type 'int' and no indicator that it's actually an unsigned type:

Image

If I don't make any change to the model, and then I try to update the database from the model, Entity Developer detects some nonexistent changes and it wants to modify the type of the column in the database:

Image
Image

The DDL that creates the sample table is:

Code: Select all

CREATE TABLE Tabla (
  Id int(10) UNSIGNED NOT NULL AUTO_INCREMENT,
  OtroInt int(10) UNSIGNED NOT NULL,
  PRIMARY KEY (Id)
)
Am I missing something?

Thanks!

Shalex
Site Admin
Posts: 9122
Joined: Thu 14 Aug 2008 12:44

Re: Problem with 'unsigned' columns

Post by Shalex » Sat 19 Oct 2019 19:21

Thank you for your report. We will investigate the issue and notify you about the result.

Shalex
Site Admin
Posts: 9122
Joined: Thu 14 Aug 2008 12:44

Re: Problem with 'unsigned' columns

Post by Shalex » Fri 01 Nov 2019 13:22

The investigation is in progress. As soon as we have any results, we will notify you.

DarkCamper
Posts: 13
Joined: Wed 18 Mar 2015 17:31

Re: Problem with 'unsigned' columns

Post by DarkCamper » Tue 18 Feb 2020 16:44

Hi! Do you have any update on this issue?

Shalex
Site Admin
Posts: 9122
Joined: Thu 14 Aug 2008 12:44

Re: Problem with 'unsigned' columns

Post by Shalex » Tue 25 Feb 2020 14:51

We are planning to provide the fix in the next version.

Post Reply