Gettting "Missing parenthesis" Error with devart 8.4.389 on 11g Oracle

Discussion of open issues, suggestions and bugs regarding Entity Framework support in ADO.NET Data providers
Post Reply
sumit.bhardwaj
Posts: 1
Joined: Mon 03 Dec 2018 14:30

Gettting "Missing parenthesis" Error with devart 8.4.389 on 11g Oracle

Post by sumit.bhardwaj » Tue 04 Dec 2018 00:05

Hi,

We are using devart 8.4.389.0 version with EF 6.1. But using FirstOrDefault()/First() is throwing Missing parenthesis error.


Query 1: (Throws error with 11g but works fine on 12c Oracle)
var temp= (from tbl1 in context.TableOne
join tbl2 in context.TableTwo
on tbl1.ID equals tbl2.ID
where tbl1.ID == 1234

select new
{
name= tbl1.name
age= tbl2.age
}).FirstOrDefault();

Query 2: (Works fine on both but then again with this change we got lots of changes in the existing code)
var temp= (from tbl1 in context.TableOne
join tbl2 in context.TableTwo
on tbl1.ID equals tbl2.ID
where tbl1.ID == 1234

select new
{
name= tbl1.name
age= tbl2.age
}).ToList().FirstOrDefault();


Can you help what is wrong here, because the same code was working earlier for both DB.

FYI : We recently installed the devart latest trial version i.e. 9.6 and then reinstalled devart 8.4.389 licensed.

Shalex
Site Admin
Posts: 8660
Joined: Thu 14 Aug 2008 12:44

Re: Gettting "Missing parenthesis" Error with devart 8.4.389 on 11g Oracle

Post by Shalex » Wed 05 Dec 2018 14:56

sumit.bhardwaj wrote:
Tue 04 Dec 2018 00:05
Query 1: (Throws error with 11g but works fine on 12c Oracle)
var temp= (from tbl1 in context.TableOne
join tbl2 in context.TableTwo
on tbl1.ID equals tbl2.ID
where tbl1.ID == 1234

select new
{
name= tbl1.name
age= tbl2.age
}).FirstOrDefault();
This query works in our environment with Oracle v11.2 and dotConnect for Oracle v9.6.646. Please upgrade.

Post Reply