EF Core

Discussion of open issues, suggestions and bugs regarding Entity Framework support in ADO.NET Data providers
Post Reply
simonbeaumont909
Posts: 3
Joined: Thu 19 Oct 2017 17:31

EF Core

Post by simonbeaumont909 » Thu 19 Oct 2017 17:58

I am trying to create DbContextOptions<TContext> using the DbContextOptionsBuilder.
When I invoke a method which then invokes builder.UseOracle I am receiving the following error:

System.TypeLoadException: 'Method 'Clone' in type 'Devart.Data.Oracle.Entity.OracleOptionsExtension' from assembly 'Devart.Data.Oracle.Entity.EFCore, Version=9.4.348.0, Culture=neutral, PublicKeyToken=09af7300eec23701' does not have an implementation.'

I have installed dot Connect for Oracle Pro v9.4.348.0
and I have the following nugget packages:
Devart.Data.Oracle.EFCore v9.4.348
Devart.Data.Oracle v9.4.348
Microsoft.EntityFrameworkCore v2.0.0

I tried uninstalling + reinstalling all do connect software and packages but any attempt to use code invoking builder.UseOracle results in System.TypeLoadException being thrown.

Has anyone else experienced this issue? My .NET Solution compiles and runs but trying to connect to oracle database via the EF Core is failing.

Shalex
Site Admin
Posts: 8241
Joined: Thu 14 Aug 2008 12:44

Re: EF Core

Post by Shalex » Fri 20 Oct 2017 10:44

dotConnect for Oracle supports only EF Core 1.1.2 at the moment. We will notify you when EF Core 2.0 and .NET Core 2.0 are supported. An approximate timeframe is one week.

As a temporary workaround, please use EF Core 1.1.2:
PM> install-package Microsoft.EntityFrameworkCore.Relational -version 1.1.2

Shalex
Site Admin
Posts: 8241
Joined: Thu 14 Aug 2008 12:44

Re: EF Core

Post by Shalex » Mon 30 Oct 2017 20:18

Entity Framework Core 2.0 is supported: viewtopic.php?f=1&t=36128.

Be aware that starting from Entity Framework Core 2.0 the Scaffold-DbContext functionality (Devart.Data.Oracle.EFCore.Design.dll) is included in the Devart.Data.Oracle.EFCore package.

Post Reply