ORA-00909, when using IQueryFilter by anything and trying to take 0 results in response.

Discussion of open issues, suggestions and bugs regarding Entity Framework support in ADO.NET Data providers
Post Reply
dzwiedziu
Posts: 3
Joined: Mon 19 Sep 2016 09:32

ORA-00909, when using IQueryFilter by anything and trying to take 0 results in response.

Post by dzwiedziu » Mon 19 Sep 2016 10:49

Hi everyone,

I encountered a strange situation where as in topic, I am filtering results for by example SDO_GEOMETRY.
Everything is just fine when I try to take "normal" number of items in response, but when I want to take 0 EF creates not valid SELEC.
It goes like this whent not valid:
SELECT
1 AS C1,
TO_NUMBER(NULL) AS C2,
TO_NUMBER(NULL) AS C3,
TO_CHAR(NULL) AS C4,
TO_CHAR(NULL) AS C5,
TO_CHAR(NULL) AS C6,
CAST(NULL AS TIMESTAMP(9)) AS C7,
TO_CHAR(NULL) AS C8,
(CASE WHEN CAST(NULL AS SDO_GEOMETRY) IS NULL THEN NULL ELSE 'SRID=' || NVL(CAST(NULL AS SDO_GEOMETRY).SDO_SRID, '0') || ';' || SDO_UTIL.TO_WKTGEOMETRY(CAST(NULL AS SDO_GEOMETRY)) END) AS C9
FROM ( SELECT 1 AS X FROM DUAL) "SingleRowTable1"
WHERE 1 = 0

And when I want filter by string it is all the same.
Anyone knows why it could be happening?

Shalex
Site Admin
Posts: 8247
Joined: Thu 14 Aug 2008 12:44

Re: ORA-00909, when using IQueryFilter by anything and trying to take 0 results in response.

Post by Shalex » Tue 20 Sep 2016 11:39

Thank you for your report. We have reproduced the issue and are investigating it. We will notify you about the result.

Shalex
Site Admin
Posts: 8247
Joined: Thu 14 Aug 2008 12:44

Re: ORA-00909, when using IQueryFilter by anything and trying to take 0 results in response.

Post by Shalex » Thu 22 Sep 2016 16:09

The bug with using Take(0) with the entity, which includes the DbGeometry or DbGeography fields, in EF5/EF6 is fixed: viewtopic.php?f=1&t=34319.

Post Reply