Installation on production machine failled

Discussion of open issues, suggestions and bugs regarding Entity Framework support in ADO.NET Data providers
Post Reply
RomainT06
Posts: 5
Joined: Fri 23 Jan 2015 09:43

Installation on production machine failled

Post by RomainT06 » Wed 01 Jul 2015 08:53

Hi,
I have developped a application with dotConnect and EF6
It works fine on my dev machine
But I am not able to lauch it on the production machine
I have copied the 3 DLL and the config file from dev but it does'nt work
Is there a reditribuable package ?
What is the minimun config file. I use 8.4.422.6
Thanks
Romain

RomainT06
Posts: 5
Joined: Fri 23 Jan 2015 09:43

Re: Installation on production machine failled

Post by RomainT06 » Wed 01 Jul 2015 12:09

I have the error
The underlying provider failed on Open

Shalex
Site Admin
Posts: 8247
Joined: Thu 14 Aug 2008 12:44

Re: Installation on production machine failled

Post by Shalex » Wed 01 Jul 2015 12:39

RomainT06 wrote:I have developped a application with dotConnect and EF6
I have copied the 3 DLL
They should be:
"C:\Program Files (x86)\Devart\dotConnect\Oracle\Devart.Data.dll"
"C:\Program Files (x86)\Devart\dotConnect\Oracle\Devart.Data.Oracle.dll"
"C:\Program Files (x86)\Devart\dotConnect\Oracle\Entity\EF6\Devart.Data.Oracle.Entity.dll" (revision *.6)
RomainT06 wrote:What is the minimun config file. I use 8.4.422.6

Code: Select all

<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <configSections>
    <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=6.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
  </configSections>
  <entityFramework>
    <providers>
      <provider invariantName="Devart.Data.Oracle" type="Devart.Data.Oracle.Entity.OracleEntityProviderServices, Devart.Data.Oracle.Entity, Version=8.4.422.6, Culture=neutral, PublicKeyToken=09af7300eec23701" />
    </providers>
  </entityFramework>
  <system.data>
    <DbProviderFactories>
      <remove invariant="Devart.Data.Oracle" />
      <add name="dotConnect for Oracle" invariant="Devart.Data.Oracle" description="Devart dotConnect for Oracle" type="Devart.Data.Oracle.OracleProviderFactory, Devart.Data.Oracle, Version=8.4.422.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />
    </DbProviderFactories>
  </system.data>
</configuration>
Replace 8.4.422 here with your current version of dotConnect for Oracle. Please note that the revision number of provider in the entityFramework section is *.6 but it should be *.0 in DbProviderFactories.

If this doesn't help, please specify the full call stack of the error with all inner exceptions.

RomainT06
Posts: 5
Joined: Fri 23 Jan 2015 09:43

Re: Installation on production machine failled

Post by RomainT06 » Thu 02 Jul 2015 08:50

Thank you very mush it works fine

Post Reply