Model Naming for FirstLetterUpperCase not working

Discussion of open issues, suggestions and bugs regarding Entity Framework support in ADO.NET Data providers
Post Reply
Posts: 4
Joined: Mon 11 Mar 2013 21:25

Model Naming for FirstLetterUpperCase not working

Post by trumbjd1 » Mon 11 Aug 2014 22:42


I am running 7.9.333.6 on an Oracle 11.2 data model in VS 2012 with the EF 6 POCO template. I am starting a project from scratch and setup the naming for the model to FirstLetterUpperCase with underscore removal on.

So, I expect this:


to be transformed to:


but what I get is:


I have tried other options like lower case and unchanged and they seem to work. But FirstLetterLowerCase looks like it is keeping everything upper case and removing the underscore.

Any idea what is happening? I could have sworn this happened to me several years ago but it was fixed in a minor release.


Devart Team
Posts: 7976
Joined: Thu 14 Aug 2008 12:44

Re: Model Naming for FirstLetterUpperCase not working

Post by Shalex » Tue 12 Aug 2014 15:40

This is a designed behaviour.

Please download ... eloper.chm > the Search tab, type "naming rules" > Database Naming:
Capitalized - the first letter of the entity name and the first letter after each underscore in the table name will be uppercase, other letters will be lowercase.
FirstLetterUppercase - the name of an entity begins with a capital letter, case of other letters will not be changed.

These are inputs/outputs depending on the selected naming rule:
Capitalized: NICE_TABLE_NAME -> NiceTableName

Post Reply