$expand is broken in WCF DataServices 5 RTM with DevArt?

Discussion of open issues, suggestions and bugs regarding Entity Framework support in ADO.NET Data providers
Post Reply
Alladin
Posts: 149
Joined: Mon 27 Nov 2006 16:18
Contact:

$expand is broken in WCF DataServices 5 RTM with DevArt?

Post by Alladin » Fri 13 Apr 2012 08:21

Hi there,

not sure who is responsible for this issue. But anyway it's worth to check out.

http://social.msdn.microsoft.com/Forums ... 46a3acfb6d

Shalex
Site Admin
Posts: 8247
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Wed 18 Apr 2012 16:59

Please put the following line in the constructor of your context (the Devart.Data.Oracle.Entity.OracleEntityProviderServices class is defined in the %ProgramFiles%\Devart\dotConnect\Oracle\Entity\EF4\Devart.Data.Oracle.Entity.dll assembly):

Code: Select all

Devart.Data.Oracle.Entity.OracleEntityProviderServices.HandleNullStringsAsEmptyStrings = true;
Refer to http://blogs.planetsoftware.com.au/paul ... d-wcf.aspx . This is actually the problem of WCF Data Services which doesn't take into account the peculiarities of other RDMS (Oracle treats empty strings in varchar columns as null).

Alladin
Posts: 149
Joined: Mon 27 Nov 2006 16:18
Contact:

Post by Alladin » Mon 23 Apr 2012 14:32

With this option active, we got WCF DataServices 5 working. However, most of our code is now broken, because all checks for null strings are now invalid (since empty strings are returned now instead of nulls).

It is possible to fix this properly? I mean, don't roundtrip constant to RDBMS for entity materialization sake?

Shalex
Site Admin
Posts: 8247
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Wed 25 Apr 2012 09:55

The problem is fixed in WCF Data Services 5.1.0 (no need to use our workaround with this version). An upgrade is a recommended way of coping with it.

We considered not to fix the issue on our side for previous versions of WCF Data Services because this requires an architectural changes in the provider (time and resource consuming task).

Post Reply