support for proxy authentication

Discussion of open issues, suggestions and bugs regarding Entity Framework support in ADO.NET Data providers
Post Reply
Micha_
Posts: 10
Joined: Mon 18 Jan 2010 18:58

support for proxy authentication

Post by Micha_ » Wed 06 Oct 2010 13:24

Is it possible to connect to an oracle database via proxy authentication?
Thanks

Shalex
Site Admin
Posts: 8247
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Mon 11 Oct 2010 15:06

Proxy Authentication is supported by dotConnect for Oracle.

If you want to have proxy connections with enabled OCI Session Pooling, specify credentials for proxy user via the Oci Session Pool User Id and Oci Session Pool Password connection string parameters.

You can also establish proxy connection with this overload of the Open() method that accepts another OracleConnection as argument.

Micha_
Posts: 10
Joined: Mon 18 Jan 2010 18:58

Post by Micha_ » Wed 13 Oct 2010 07:19

Thank you Shalex,

finally I got it to work. But only for normal database users (database user is connectes connected through the proxy user).
In our case we want to use proxy authentication with Enterprise Users. We have an Oracle OID that manages our Enterprise Users. All Enterprise Users are mapped on a shared shema in the database. Therefore I granted "connect through" to this shared shema:

alter user shared_shema grant connect through midtier authenticated using distinguished name;

midtier is in our case the proxy user. If I try to connect with the Oracle Sql Developer the configuration works fine. But if I try connect with devart it fails saying that I use a wrong user name or a wrong password.
Is there something special with Enterprise Users that has to be taken into account?

Shalex
Site Admin
Posts: 8247
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Mon 18 Oct 2010 13:31

We are investigating the issue.

1. Please check if your settings are valid by establishing proxy connection with your Enterprise User using ODP.NET: http://download.oracle.com/docs/html/E1 ... m#i1006514. Does it work?

2. Please show us your code with connection string you are using with dotConnect for Oracle. Is "midtier" your Enterprise User?

3. Tell us the version of your Oracle Server (xx.x) and dotConnect for Oracle (x.xx.xxx). You can find the version of dotConnect for Oracle via the Tools > Oracle > About menu of Visual Studio.

Micha_
Posts: 10
Joined: Mon 18 Jan 2010 18:58

Post by Micha_ » Wed 20 Oct 2010 15:51

Hi Shalex,

sorry for the long response time.
1. I tried to establishing a proxy connection my Enterprise User using ODP.NET. It worked well with the following connection string:
User Id=micha.test; Data Source=database;Proxy User Id=midtier; Proxy Password=pass;

As you can see midtier is the proxy user and micha.test the Enterprise User managed within Oracle OID.

2. Here is the code with connection string which I am using with dotConnect for Oracle:

string cs_dataModel = "metadata=res://*/FikoDataModel.csdl|res://*/FikoDataModel.ssdl|res://*/FikoDataModel.msl;provider=Devart.Data.Oracle;provider connection string=\"" +
"User Id=micha.test;Home=oraclient10g_home1;Direct=False;Oci Session Pooling=True;Oci Session Pool User Id=midtier;Oci Session Pool Password=pass;Sid=database;Persist Security Info=False\"";

ModelEntities dataModelContext = new ModelEntities(cs_dataModel);

var query = from r in dataModelContext.Op
select r;

Again midtier is the proxy user and micha.test the Enterprise User managed within Oracle OID.

3.
version of our Oracle Server: 10.2.0.3.0
version of dotConnect for Oracle (5.60.124.0)

Thank you!!!

Micha_
Posts: 10
Joined: Mon 18 Jan 2010 18:58

Post by Micha_ » Wed 20 Oct 2010 15:57

to be concrete...
if I try to connect with dotConnect for Oracle I get the error message: ORA-01017: invalid username/password; logon denied

but I am using the same password and username like I used for the ODP.NET connection

Micha_
Posts: 10
Joined: Mon 18 Jan 2010 18:58

Post by Micha_ » Tue 23 Nov 2010 13:52

are there any results by now?

Shalex
Site Admin
Posts: 8247
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Fri 26 Nov 2010 14:14

We are investigating the issue. I will post here about the first available result.

Post Reply