EF Core 3.0 Support

Discussion of open issues, suggestions and bugs regarding Entity Framework support in ADO.NET Data providers
Post Reply
mpearse
Posts: 8
Joined: Mon 02 Feb 2015 00:00

EF Core 3.0 Support

Post by mpearse » Tue 01 Oct 2019 04:16

Hi,

Is Entity Framework Core 3.0 supported at the moment or is support to come in the future?

Just checking the behaviour we are getting isn't unexpected (using dotConnect for PostgreSQL 7.14).

Was starting a new project with Core 3.0. We tried out EF Core 3.0 first, but ran into a missing method exception when calling 'UsePostgreSql'.
ie
var optionsBuilder = new DbContextOptionsBuilder<myModel>();
optionsBuilder.UsePostgreSql(myPgSqlConnection, (a) => { ... });

I've used the new EF 6.3 support successfully with Core 3.0 so for now we are starting with that. However ideally we would be using EF Core. So if the status of Entity Framework Core 3.0 support could be clarified that'd be great

Thanks

Shalex
Site Admin
Posts: 8829
Joined: Thu 14 Aug 2008 12:44

Re: EF Core 3.0 Support

Post by Shalex » Tue 01 Oct 2019 19:16

EF Core 3 is currently not supported by dotConnect for PostgreSQL. We are working on the feature. We will do our best to implement it as soon as possible.

mpearse
Posts: 8
Joined: Mon 02 Feb 2015 00:00

Re: EF Core 3.0 Support

Post by mpearse » Wed 09 Oct 2019 23:24

Thanks. Having done some more reading, we now prefer 6.3 anyway and will be sticking there.

Post Reply