Cannot License After Framework Upgrade

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for PostgreSQL
Post Reply
s4duser
Posts: 2
Joined: Fri 24 Jul 2020 08:32

Cannot License After Framework Upgrade

Post by s4duser » Fri 24 Jul 2020 08:38

Hi. I have been using dotconnect for many years (version 7.3.201.0) and had no issues at all until I just upgraded my project to use .NET Framework 4.7.2. Now whenever I try to open my database it says Assembly is not licensed to use dotConnect. Nothing has changed in the licenses. The same license line in the Licenses.licx file is still there, in fact if I take it back to 4.5.2 everything works fine, however because we need to use other technologies that require 4.7.2 we are forced to upgrade.

Can you tell me how to fix this?

Thanks

Lee

Shalex
Site Admin
Posts: 9164
Joined: Thu 14 Aug 2008 12:44

Re: Cannot License After Framework Upgrade

Post by Shalex » Sat 25 Jul 2020 10:00

.NET Framework 4.7.2 (Visual Studio 2017) is supported by dotConnect for PostgreSQL starting from v7.8.862: https://www.devart.com/dotconnect/postg ... story.html. Please upgrade your version.

Post Reply