Errors on installing into a netcore2.0 project

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for PostgreSQL
Post Reply
EvilShrike
Posts: 19
Joined: Mon 14 Mar 2016 17:11

Errors on installing into a netcore2.0 project

Post by EvilShrike » Wed 23 Aug 2017 14:27

I've tried to install Devart.Data.PostreSql v.7.9.958 from nuget.org into a netcore2.0 project (inside VS2017.3). It fails with the following error.
The same error happens for SQLite provider. I didn't tried other ones.

Code: Select all

Restoring packages for D:\Work\...\Xtensive.Sql.PostgreSql.csproj...
Detected package downgrade: System.Net.Primitives from 4.3.0 to 4.0.11. Reference the package directly from the project to select a different version. 
 Xtensive.Sql.PostgreSql (>= 1.0.0) -> Devart.Data.PostgreSql (>= 7.9.958) -> NETStandard.Library (>= 1.6.1) -> System.Net.Primitives (>= 4.3.0) 
 Xtensive.Sql.PostgreSql (>= 1.0.0) -> Devart.Data.PostgreSql (>= 7.9.958) -> System.Net.Primitives (>= 4.0.11)
Detected package downgrade: System.Runtime.InteropServices.RuntimeInformation from 4.3.0 to 4.0.0. Reference the package directly from the project to select a different version. 
 Xtensive.Sql.PostgreSql (>= 1.0.0) -> Devart.Data.PostgreSql (>= 7.9.958) -> NETStandard.Library (>= 1.6.1) -> System.Runtime.InteropServices.RuntimeInformation (>= 4.3.0) 
 Xtensive.Sql.PostgreSql (>= 1.0.0) -> Devart.Data.PostgreSql (>= 7.9.958) -> System.Runtime.InteropServices.RuntimeInformation (>= 4.0.0)
Detected package downgrade: System.Security.Cryptography.Algorithms from 4.3.0 to 4.2.0. Reference the package directly from the project to select a different version. 
 Xtensive.Sql.PostgreSql (>= 1.0.0) -> Devart.Data.PostgreSql (>= 7.9.958) -> NETStandard.Library (>= 1.6.1) -> System.Security.Cryptography.Algorithms (>= 4.3.0) 
 Xtensive.Sql.PostgreSql (>= 1.0.0) -> Devart.Data.PostgreSql (>= 7.9.958) -> System.Security.Cryptography.Algorithms (>= 4.2.0)
Detected package downgrade: System.Security.Cryptography.Csp from 4.3.0 to 4.0.0. Reference the package directly from the project to select a different version. 
 Xtensive.Sql.PostgreSql (>= 1.0.0) -> Devart.Data.PostgreSql (>= 7.9.958) -> NETStandard.Library (>= 1.6.1) -> System.Security.Cryptography.X509Certificates (>= 4.3.0) -> System.Security.Cryptography.Csp (>= 4.3.0) 
 Xtensive.Sql.PostgreSql (>= 1.0.0) -> Devart.Data.PostgreSql (>= 7.9.958) -> System.Security.Cryptography.Csp (>= 4.0.0)
Package restore failed. Rolling back package changes for 'Xtensive.Sql.PostgreSql'.
Any ideas?

via dotnet CLI tool it can be installed but when opened in VS it produces the same errors:

Error NU1605 Detected package downgrade: System.Net.Primitives from 4.3.0 to 4.0.11. Reference the package directly from the project to select a different version.
devart_sqlite (>= 1.0.0) -> Devart.Data.SQLite (>= 5.9.958) -> NETStandard.Library (>= 1.6.1) -> System.Net.Primitives (>= 4.3.0)
devart_sqlite (>= 1.0.0) -> Devart.Data.SQLite (>= 5.9.958) -> System.Net.Primitives (>= 4.0.11) devart_sqlite D:\Work\Learn\dotnet\devart_sqlite\devart_sqlite.csproj 1

Shalex
Site Admin
Posts: 8245
Joined: Thu 14 Aug 2008 12:44

Re: Errors on installing into a netcore2.0 project

Post by Shalex » Thu 24 Aug 2017 11:14

EvilShrike wrote:I've tried to install Devart.Data.PostreSql v.7.9.958 from nuget.org into a netcore2.0 project (inside VS2017.3). It fails with the following error.
.NET Core 2.0 is currently not supported. We are working on the feature and will notify you when it is implemented.

EvilShrike
Posts: 19
Joined: Mon 14 Mar 2016 17:11

Re: Errors on installing into a netcore2.0 project

Post by EvilShrike » Thu 24 Aug 2017 11:19

.NET Core 2.0
Oh. Then please add some note onto https://www.devart.com/dotconnect/postg ... tions.html page as it states ".NET Core support". So does for all other your providers.
I wasted so much time on this..
For me ".NET Core support" means .NET Core 2.0 as well. Does it only work on 1.x?

Shalex
Site Admin
Posts: 8245
Joined: Thu 14 Aug 2008 12:44

Re: Errors on installing into a netcore2.0 project

Post by Shalex » Mon 28 Aug 2017 11:33

EvilShrike wrote:Oh. Then please add some note onto https://www.devart.com/dotconnect/postg ... tions.html page as it states ".NET Core support". So does for all other your providers.
I wasted so much time on this..
For me ".NET Core support" means .NET Core 2.0 as well.
Thank you for your suggestion.
EvilShrike wrote:Does it only work on 1.x?
dotConnect for PostgreSQL supports .NET Standard 1.3.

EvilShrike
Posts: 19
Joined: Mon 14 Mar 2016 17:11

Re: Errors on installing into a netcore2.0 project

Post by EvilShrike » Mon 28 Aug 2017 13:29

If it supports NetStandard1.3 then it should support NetCore2.0 as well.
Actually right after the package installed build fails but adding theses packages makes it succeed:

Code: Select all

    <PackageReference Include="System.Net.Primitives" Version="4.3.0" />
    <PackageReference Include="System.Reflection" Version="4.3.0" />
    <PackageReference Include="System.Runtime.InteropServices.RuntimeInformation" Version="4.3.0" />
    <PackageReference Include="System.Security.Cryptography.Algorithms" Version="4.3.0" />
    <PackageReference Include="System.Security.Cryptography.Csp" Version="4.3.0" />
Hope you'll release a package which wouldn't require such overriding.

Do I understand correctly that currently these're no trial versions for netcore?

Shalex
Site Admin
Posts: 8245
Joined: Thu 14 Aug 2008 12:44

Re: Errors on installing into a netcore2.0 project

Post by Shalex » Mon 28 Aug 2017 16:19

EvilShrike wrote:Do I understand correctly that currently these're no trial versions for netcore?
There is a trial period for .NET Core assemblies as well: https://www.devart.com/dotconnect/oracl ... ndard.html.

EvilShrike
Posts: 19
Joined: Mon 14 Mar 2016 17:11

Re: Errors on installing into a netcore2.0 project

Post by EvilShrike » Tue 29 Aug 2017 10:12

Some update.
I can confirm that with mentioned package references a project can build on netcoreapp2.0 and run (both on windows/linux).

To build and run on net462 there should be one more package added:

Code: Select all

  <ItemGroup>
    <PackageReference Include="Devart.Data.PostgreSql" Version="7.9.958" />
    <PackageReference Include="System.IO.FileSystem.Primitives" Version="4.3.0" />
    <PackageReference Include="System.Net.NameResolution" Version="4.3.0" />
    <PackageReference Include="System.Net.Primitives" Version="4.3.0" />
    <PackageReference Include="System.Reflection" Version="4.3.0" />
    <PackageReference Include="System.Runtime.InteropServices.RuntimeInformation" Version="4.3.0" />
    <PackageReference Include="System.Security.Cryptography.Algorithms" Version="4.3.0" />
    <PackageReference Include="System.Security.Cryptography.Csp" Version="4.3.0" />
  </ItemGroup>
  <ItemGroup Condition="'$(TargetFramework)' == 'net462'">
    <PackageReference Include="System.Security.Principal.Windows" Version="4.3.0" />
  </ItemGroup>

Shalex
Site Admin
Posts: 8245
Joined: Thu 14 Aug 2008 12:44

Re: Errors on installing into a netcore2.0 project

Post by Shalex » Wed 30 Aug 2017 14:35

Thank you for your feedback.

EvilShrike
Posts: 19
Joined: Mon 14 Mar 2016 17:11

Re: Errors on installing into a netcore2.0 project

Post by EvilShrike » Wed 30 Aug 2017 18:12

Please see this issue I created in corefx repo for NU1605 error - https://github.com/dotnet/core/issues/9 ... -326072536

Shalex
Site Admin
Posts: 8245
Joined: Thu 14 Aug 2008 12:44

Re: Errors on installing into a netcore2.0 project

Post by Shalex » Mon 30 Oct 2017 19:40

.NET Core 2.0 is supported: viewtopic.php?f=3&t=36126.

Post Reply