Page 1 of 1

License not found unless dotConnect installed

Posted: Tue 24 Jan 2017 19:38
by jsonlu
Hi guys,

I'm having trouble deploying my project to other computers without a "License not found" message.
First, some details:
It is built with Visual Studio, and the license.licx is an embedded resource. It is using Version 7.7.819.0. The executable is made with Inno Script Studio and I've made sure to include the Devart.Data, Devart.Data.Linq, Devart.Data.PostgreSql, Devart.Data.PostgreSql.Linq dlls.

I don't know what else I need to do, but I'm pretty sure it's the license causing problems.

I have found that if I install dotConnect onto the machines I want to deploy to, the license not found error goes away. Any help is appreciated, thanks!

Re: License not found unless dotConnect installed

Posted: Wed 25 Jan 2017 17:34
by Shalex
jsonlu wrote:I have found that if I install dotConnect onto the machines I want to deploy to, the license not found error goes away.
That is a designed behavior, but also you should be able to deploy your application without installing dotConnect for PostgreSQL.
jsonlu wrote:I'm having trouble deploying my project to other computers without a "License not found" message.
1. If you are using a trial of dotConnect for PostgreSQL Professional, licenses.licx should include:

Code: Select all

Devart.Data.PostgreSql.PgSqlConnection, Devart.Data.PostgreSql
Devart.Data.PostgreSql.Linq.Provider.PgSqlDataProvider, Devart.Data.PostgreSql.Linq
2. If you are using a licensed version of dotConnect for PostgreSQL Professional, licenses.licx should include only this line:

Code: Select all

Devart.Data.PostgreSql.PgSqlConnection, Devart.Data.PostgreSql
Does this help?

Re: License not found unless dotConnect installed

Posted: Wed 25 Jan 2017 22:23
by jsonlu
Yes, that's useful information to know. Though I have reason to believe we are using a paid license because when I looked at the code, licenses.licx only had two Devart references. How can I find that I have a paid license installed? This development computer was given to me with little information.

The version of dotConnect was 7.3.xx back then and I've downloaded the 7.7 version Professional Trial to try and fix things, does that mean if I had a license, it won't work for the 7.7 files?
Edit: looks like it won't work from the FAQ

Edit: also the License Manager in the Visual Studio tools says everything is fine, but obviously it is not.

Edit 2: so apparently when we bought the license, it was for version 7.3.2xx but when I was given the machine, we had dotConnect 7.3.344. Is that small of an upgrade enough to void the license?

Re: License not found unless dotConnect installed

Posted: Thu 26 Jan 2017 10:25
by Shalex
jsonlu wrote:I've downloaded the 7.7 version Professional Trial to try and fix things, does that mean if I had a license, it won't work for the 7.7 files?
There are two installation types of dotConnect for PostgreSQL Professional:
1) trial -> available at http://www.devart.com/dotconnect/postgr ... nload.html
2) licensed -> can be downloaded from Customer Portal (link and credentials are provided by our Sales department)

You can check your current version via the Tools > PostgreSQL > About menu of Visual Studio. Is there a "Trial" suffix in the name of the product?

Re: License not found unless dotConnect installed

Posted: Thu 26 Jan 2017 18:06
by jsonlu
So I went ahead and purchased a new Professional License and that seemed to have fixed the issue.

My guess is that the problem was that there was a version mismatch between the licensed that was purchased and the actual files that were downloaded. It was also odd that the Visual Studio tools were not installed before, so it was more difficult to see the problem.

Thanks for your help!