DotConnect don't map a Views

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for PostgreSQL
Post Reply
Simone Torri
Posts: 11
Joined: Wed 07 Sep 2016 11:23

DotConnect don't map a Views

Post by Simone Torri » Wed 07 Sep 2016 11:58

Hello,
i'm tryng dotConnect for PostgreSQL to mapping a database using database first method, dbContext template, but if i check any views in the VisualStudio mapping wizard, do not appeare the classes of EntityModel objects, and i see in an empty file with .info extension this message "// Custom tool 'DevartEfGenerator' failed."

I tried too to mapping only one very simple view created in postGree with this statement "SELECT 1" but don't work too...

I need an help!

Thankyou very match
ST

Shalex
Site Admin
Posts: 8246
Joined: Thu 14 Aug 2008 12:44

Re: DotConnect don't map a Views

Post by Shalex » Wed 07 Sep 2016 17:30

Have you defined Entity Key for your view in both conceptual and *.Store parts of the model? Please check this via Tools > Entity Developer > Model Explorer. If this doesn't help, send us a small test project so that we can reproduce the "Custom tool 'DevartEfGenerator' failed." error in our environment.

In case of >2MB attachment, we recommend either using some file exchange server (send us the corresponding link) or uploading a test project to our FTP server (the credentials will be provided by email request).

Simone Torri
Posts: 11
Joined: Wed 07 Sep 2016 11:23

Re: DotConnect don't map a Views

Post by Simone Torri » Mon 12 Sep 2016 15:40

Thanckyou i don't defined it... now it's ok

Post Reply