Getting error when try to connect to SSAS

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for PostgreSQL
Post Reply
moonpie
Posts: 4
Joined: Mon 09 Nov 2015 15:54

Getting error when try to connect to SSAS

Post by moonpie » Tue 02 Aug 2016 09:00

Hi!
I try to create OLAP-project using your driver and get some error.
I have successfully created data source to PG-server, it get schemas and tables from there.
When I try to add any table on DataSourceView I get error syntax error at or near "["
I see on other threads that you send some specific xsl file to the users in order to try to resolve this issue. Can I get the same file to test it?
Thanks.

Pinturiccio
Devart Team
Posts: 2192
Joined: Wed 02 Nov 2011 09:44

Re: Getting error when try to connect to SSAS

Post by Pinturiccio » Wed 03 Aug 2016 13:06

When you install dotConnect for PostgreSQL you need to restart the "SQL Server Analysis Services" service or your computer. After the restart it should work.

If the "syntax error at or near "["." exception still occurs after restarting, please make sure that the Devart.Data.PostgreSql.xsl file is present in the following locations:
Program Files\Microsoft SQL Server\%Your SQL Server Instance%\Tools\Binn\VSShell\Common7\IDE\DataWarehouseDesigner\UIRdmsCartridge
Program Files\Microsoft Visual Studio x\Common7\IDE\PrivateAssemblies\DataWarehouseDesigner\UIRdmsCartridge\
Program Files\Microsoft Visual Studio x\Common7\IDE\PrivateAssemblies\Business Intelligence Semantic Model\Cartridges

We will also send this file to you via email.

Post Reply