How to deal with 2 versions of dotConnect

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for PostgreSQL
Post Reply
JORGEMAL
Posts: 168
Joined: Thu 03 Jul 2008 23:55

How to deal with 2 versions of dotConnect

Post by JORGEMAL » Sun 18 Mar 2012 21:35

I have 2 web projects in my development PC, both of them work with dotConnect for PostgreSQL 5.50. I would like to upgrade only one of the projects to dotConnect 5.80 and continue using version 5.50 with the other one. Nevertheless, I see that I cannot have both versions of dotConnect installed in my development PC. How can I maintain a project that runs with dotConnect 5.50 and another running with dotConnect 5.80?

Respectfully,
Jorge Maldonado

Shalex
Site Admin
Posts: 8241
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Mon 19 Mar 2012 08:35

Development.
We do not recommend to install several versions of dotConnect for PostgreSQL in the development environment because design time will not work correctly in this situation.

Deployment.
You can use several versions of dotConnect for PostgreSQL in your deployment environment. Two approaches:
1) placing the Devart.* assemblies of the corresponding version in the bin folders of your applications;
2) using "Minimal installation" for several versions of dotConnect for PostgreSQL on the same workstation:
a) delete the HKEY_LOCAL_MACHINE\SOFTWARE\Devart\Installed Products\dotConnect\Net2\PostgreSQL key before each new provider installation;
b) be aware that each dotConnect for PostgreSQL installation package places the policy.*.Devart.* files to GAC. If you use several versions of our provider, you should remove these policy files from your GAC.

JORGEMAL
Posts: 168
Joined: Thu 03 Jul 2008 23:55

Post by JORGEMAL » Tue 20 Mar 2012 14:22

Thanks for your reply.
I use approach (1) in our production server.
Does dotConnect for PostgreSQL v5.50 have support for PostgreSQL v9.1?

Regards,
Jorge Maldonado

Shalex
Site Admin
Posts: 8241
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Wed 21 Mar 2012 10:44

We recommend using the latest 5.80.325 version of dotConnect for PostgreSQL. The 5.50 version should also support PostgreSQL 9.1. If you encounter any difficulties, please contact us.

Post Reply