foreign key relationships not working anymore

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for PostgreSQL
Post Reply
akash.hegde@gmail.com
Posts: 15
Joined: Sat 26 Nov 2011 00:56

foreign key relationships not working anymore

Post by akash.hegde@gmail.com » Sun 11 Mar 2012 06:53

Hi there
I'm using entity developer to update my model from the database (postgresql). This used to work perfectly well however all of a sudden, when i use the "Update model from database" option to add in new tables, the foreign key constraints don't get created. why is this happening all of a sudden? I have checked the database and the foreign key constraints are definetely in place....

Shalex
Site Admin
Posts: 8241
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Mon 19 Mar 2012 09:23

We cannot reproduce the problem with the latest (5.80.325) version of dotConnect for PostgreSQL. A test DDL script is sent to you by e-mail.

akash.hegde@gmail.com
Posts: 15
Joined: Sat 26 Nov 2011 00:56

Post by akash.hegde@gmail.com » Mon 19 Mar 2012 11:14

Yes i have the latest version of dotconnect running 5.80.325.

I just tried the sample 2 tables you sent me and it has the same issue. After i do a "Update model from database", the tables / classes are created, however the foreign key constraint or any association between the 2 tables is not present.

akash.hegde@gmail.com
Posts: 15
Joined: Sat 26 Nov 2011 00:56

Post by akash.hegde@gmail.com » Mon 19 Mar 2012 12:13

I have emailed you the data model.
Thanks

Post Reply