Discussion of open issues, suggestions and bugs regarding ADO.NET provider for PostgreSQL
Post Reply
Posts: 165
Joined: Thu 03 Jul 2008 23:55


Post by JORGEMAL » Mon 01 Jun 2009 15:33

I just changed my PC and installed all the tools needed for my project development. I had been working with dotConnect for PostgreSQL 4.0 in my old machine and now I installed v4.5. When I tried to create the database I got the following error message:

SQL Error: could not connect to server: Connection refused (0x0000274D/10061)
Is the server running on host "localhost" an accepting TCP/IP connections on port 5432?

I have already given the necessary rights to the directory where the DB needs to be created; I included the "postgres" user and gave "full control" access. I checked the "postgresql.conf" file and the "listen_addresses" options has a value of "*" meaning that the server listens on all ports.

PostgreSQL version in the old PC is 8.3.1 and in the new PC is 8.3.7. If I install version 8.3.1 everything works fine.

I will very much appreciate your advice.

Jorge Maldonado[/url]

Devart Team
Posts: 7968
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Tue 02 Jun 2009 12:45

Dear JORGEMAL, this question exceeds the goals of our support. Probably, you didn't configure the pg_hba.conf file of your PostgreSQL 8.3.7. Please open this file in the text editor and add necessary entries to the IPv4 section. For example:

Code: Select all

# this entry allows connections to the database from the local machine
host    all         all          md5

# this entry allows connections to the database from the paticular remote host
host    all         all         md5

# this entry allows all connections
host    all         all         password
Please refer to the PostrgreSQL documentation for the detailed information.

Post Reply