Cannot find component by name (some name) in global components cache

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for PostgreSQL
Post Reply
Posts: 1
Joined: Wed 21 May 2008 07:35
Location: Lithuania

Cannot find component by name (some name) in global components cache

Post by bixaz_ » Wed 21 May 2008 07:50

Hello, i've been working with PosgreSQLDirect for a short time, so it may be my mistake, but...

The poin is that i'm trying to get data from a DB. I created a custom user controll and tried to add a data set to it using PostgrSQLDirect DataSet Wizard. The wizard generated for me the conection, dataAdapter and a sqlCommand. Then I added the controll to a Form tried to run it. I got this exception:
Exception has been thrown by the target of an invocation
InnerException in it was:
Cannot find component by name WarehouseList.pgSqlCommand17 in global components cache

With debbuger i found out, that this exception is thowed by this line:

// pgSqlDataAdapter1
this.pgSqlDataAdapter1.TableMappings.AddRange(new System.Data.Common.DataTableMapping[] {
new System.Data.Common.DataTableMapping("Table", "wrh_select_warehouse", new System.Data.Common.DataColumnMapping[] {
new System.Data.Common.DataColumnMapping("code", "code"),
new System.Data.Common.DataColumnMapping("name", "name"),
new System.Data.Common.DataColumnMapping("country_name", "country_name"),
new System.Data.Common.DataColumnMapping("city_name", "city_name")})});
this.pgSqlDataAdapter1.SelectCommand = ((CoreLab.PostgreSql.PgSqlCommand)(CoreLab.Common.GlobalComponentsCache.GetObjectByName("WarehouseList.pgSqlCommand17")));

Am I doing something wrong?

P.S. I'm using PostgeSQL 8 and .NET 3.5 with MS VS 08

Posts: 729
Joined: Thu 13 Dec 2007 10:24

Post by Alexey.mdr » Wed 21 May 2008 09:07

Please send me (alexeyman*crlab*com) a small test project to reproduce the problem.
It is desirable to use 'test' schema objects, otherwise include the
definition of your own database objects.
Do not use third party components.
If it is impossible for you to create the test project, send us a piece of
your code where the error occurs.

Post Reply