Problems with Visual Studio after uninstall

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for PostgreSQL
Post Reply
DraconPern
Posts: 1
Joined: Sat 09 Feb 2008 04:48

Problems with Visual Studio after uninstall

Post by DraconPern » Sun 17 Feb 2008 03:59

Ever since I uninstalled after a trial, I get a package load failure everytime I start VS2005 and vs2008. THe message says "Package 'CoreLab.Data.Vs.CoreLabDataProviderPackage' has failed to load properly (GUID = 074D948*-E0E8-46D6-8ACE-E7D3152B733} ). Please contact package vendor for assistance. Application restart is reommended, due to possible environment corruption. WOuld you like to disable loading this package in the future? You may use 'devenv /resetskippkgs' to re-enable package loading."

Help!

Alexey.mdr
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Post by Alexey.mdr » Mon 18 Feb 2008 12:08

Please specify what product edition and version do you use?
What .NET Framework do you work with?
What's your OS?

unyttig
Posts: 1
Joined: Tue 08 Apr 2008 11:41

Post by unyttig » Tue 08 Apr 2008 11:44

I get the same problem.

I use Visual Studio 2008, however the problem also occures when using VS2005. In addition to the error message, there is always en empty window open when I start VS2008. Although it's possible to close it, it is really annoying because it pops up every time I run the application in debug mode. Can you please help me?

I guess I have to remove som left over files or remove some lines from a configuration file or something?

By the way, I use Win XP SP2 and have installed .NET 3.5. However, my application runs on .NET 2.0

PS. The "window" I'm talking about is the toolbox that used to contain the Dataset Manager and Editor. This toolbox is opened every time I launch VS2008. And if I close it, it pops up when I debug my application.

Alexey.mdr
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Post by Alexey.mdr » Tue 08 Apr 2008 12:59

Please send me (alexeyman*crlab*com) several screenshots to illustrate the problem.
Specify the version and edition of PostgreSQLDirect .NET.

Devman
Posts: 5
Joined: Fri 13 Jun 2008 16:05
Location: UK

Post by Devman » Fri 15 Aug 2008 10:14

I have the same problem after uninstalling OraDirect.Net
How annoying :-(


everytime i open a vs2008 poject i get;
"The CoreLab.Data.Vs.CoreLabDataProviderPackage ({074D6159-E0E8-46D6-8ACE-E7D3152BF733}) did not load because of previous errors. For assistance, contact the package vendor. To attempt to load this package again, type 'devenv /resetskippkgs' at the command prompt."

Devman
Posts: 5
Joined: Fri 13 Jun 2008 16:05
Location: UK

Post by Devman » Fri 15 Aug 2008 10:34

Fixed, Need to hack out the package from the registry so that VS doesn't attempt to load it. :-)


was located here for me, delete this at your own risk;
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\9.0\Packages
\{074D6159-E0E8-46D6-8ACE-E7D3152BF733}

Leif Mønnike
Posts: 1
Joined: Sun 05 Jul 2009 13:48

Post by Leif Mønnike » Sun 27 Sep 2009 14:13

I do not understand this solution ?? To hack this package out of the registration manually ?? I would really like the package to be active what ever function it has.

I have installed Visual Studio 2008 Professional 90 days Trial and get this strange message:

The CoreLab.Data.Vs.CoreLabDataProviderPackage ({074D6159-E0E8-46D6-8ACE-E7D3152BF733}) did not load because of previous errors. For assistance, contact the package vendor. To attempt to load this package again, type 'devenv /resetskippkgs' at the command prompt.

There must be a better solution ?

Shalex
Devart Team
Posts: 8032
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Mon 28 Sep 2009 16:28

Please launch your Visual Studio from the command line with the following option:
\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\devenv.exe /resetskippkgs

Post Reply