Registry information is damaged or missing. Make sure the provider is installed and registered correctly

Discussion of open issues, suggestions and bugs regarding UniDAC (Universal Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
moezzz
Posts: 2
Joined: Fri 08 Feb 2019 10:12

Registry information is damaged or missing. Make sure the provider is installed and registered correctly

Post by moezzz » Wed 27 May 2020 11:21

Hello

I have a license for the Unidac components that I have used for years to connect to SQL SERVER databases.
I recently switched to a SQL SERVER 2017 database in 64 Bits

The configuration is as follows:
  • Windows 10 Professional 64 Bits
  • SQL Server 2017 64 Bits
  • Embaracedro DELPHI 10.3.1
  • UNIDAC Professional Edition 7.4.12
I can easily connect with Microsoft SQL Server Management Studio 18 on my migrated SQL Server databases.
But the program hangs when I want to connect using my UNIDAC components with the following message that appears each time : Registry information is damaged or missing. Make sure the provider is installed and registered correctly.

What is the solution, please, to remedy this problem?

thank you in advance

ertank
Posts: 160
Joined: Wed 13 Jan 2016 16:00

Re: Registry information is damaged or missing. Make sure the provider is installed and registered correctly

Post by ertank » Wed 27 May 2020 12:14

Hello,

Just to clarify your problem further it might help to provide answers to below questions
- Do you have problem establishing a connection in Delphi IDE?
- Is your EXE file 64Bit?

Thanks & regards,
Ertan

moezzz
Posts: 2
Joined: Fri 08 Feb 2019 10:12

Re: Registry information is damaged or missing. Make sure the provider is installed and registered correctly

Post by moezzz » Wed 27 May 2020 13:00

Hello
Yes i can't do a connection in Delphi IDE.
My EXE is in 32 Bits.
In the capture , you can see message triggred when i try to connect to the database.
Image

Thank you.

Stellar
Devart Team
Posts: 359
Joined: Tue 03 Oct 2017 11:00

Re: Registry information is damaged or missing. Make sure the provider is installed and registered correctly

Post by Stellar » Mon 01 Jun 2020 09:36

If you use the prAuto provider and you don't have the SQL Native Client installed on your machine,
SDAC will use the provider preinstalled with Windows that has limited functionality (prSQL - Microsoft OLE DB Provider for SQL Server). To solve the issue, you can use the provider prDirect or install SQL Native Client on your machine.

UniConnection1.SpecificOptions.Values['Provider'] := 'prDirect';

Post Reply