Unicode

Discussion of open issues, suggestions and bugs regarding UniDAC (Universal Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
stvhui
Posts: 2
Joined: Wed 03 Feb 2016 08:30

Unicode

Post by stvhui » Sat 24 Aug 2019 01:45

Hello to you,
I'm using Delphi7 (32bit), Unidac 7.4.12
Connect to MySQL Database
In MySQL data contains Chinese character, that can shown from MySql Table.
I'm new in delphi also in unidac components
The Problem is When using unidac to load the database table that contains chinese character it shown ??? (three question mark).
I tried to put code :
UniConnection1.SpecificOptions.Values['UseUnicode'] := 'true';
But still not works, why?
Please guide me and thanks in advance.

Regards,
Steven

ViktorV
Devart Team
Posts: 2855
Joined: Wed 30 Jul 2014 07:16

Re: Unicode

Post by ViktorV » Tue 27 Aug 2019 10:15

Unfortunately, we can't reproduce the issue.
Could you please try to reproduce it in our UniDacDemo demo project and let us know the results? You can find this project in the: %UniDACDemos%\UniDacDemo folder, where %UniDACDemos% is the path to UniDAC Demo projects on your computer.

Post Reply