AV in TVirtualQuery & TBlob fields

Discussion of open issues, suggestions and bugs regarding UniDAC (Universal Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
MaximG
Devart Team
Posts: 1357
Joined: Mon 06 Jul 2015 11:34

Re: AV in TVirtualQuery & TBlob fields

Post by MaximG » Mon 17 Sep 2018 05:38

The link for downloading the night build, which include the required changes were sent to your email

Samuel
Posts: 23
Joined: Fri 11 Feb 2011 12:36
Location: Brazil

Re: AV in TVirtualQuery & TBlob fields

Post by Samuel » Mon 17 Sep 2018 12:36

Thanks for submitting the link, but the issue has not been resolved.

If the table has only one field, the update occurs correctly, but if it has two or more fields AV occurs when executing the UPDATE.

See the example below (AV occurs when you click the first button):

https://1drv.ms/u/s!Al-1RWjYXpnakLopmUq9lvqnTcjZRg

Samuel
Posts: 23
Joined: Fri 11 Feb 2011 12:36
Location: Brazil

Re: AV in TVirtualQuery & TBlob fields

Post by Samuel » Tue 18 Sep 2018 12:52

I installed version 7.3.10 of Unidac (released today) and for while, I did not find any AVs with the BLOB fields in Virtual Tables.

I'll continue the tests and if I find any issues I'll let you know.

Thank you.

MaximG
Devart Team
Posts: 1357
Joined: Mon 06 Jul 2015 11:34

Re: AV in TVirtualQuery & TBlob fields

Post by MaximG » Tue 18 Sep 2018 13:02

We are glad to see the problem resolved. Please don't hesitate to contact us with questions concerning UniDAC usage.

Post Reply