PostgreSQL 13.2 and UniDac 8.4.3 BUG!!

Discussion of open issues, suggestions and bugs regarding UniDAC (Universal Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
Aggie85
Posts: 93
Joined: Wed 11 Nov 2015 17:03

PostgreSQL 13.2 and UniDac 8.4.3 BUG!!

Post by Aggie85 » Sat 01 May 2021 01:29

Howdy!

I am using C++ Builder 10.4.2 with UniDac 8.4.3 connecting to a PostgreSQL 13.x database.

If I drop a TUniConnection on a data module and fill everything in and check the Connected property, I can successfully connect to the database and make queries.

If I set the TUniConnection properties at run-time and set Connected = True, the database property is cleared (i.e. not connected to a database). I get no error message, etc.

For now, I can leave my connection hard coded while I develop my app.

All the best,

Aggie85

Aggie85
Posts: 93
Joined: Wed 11 Nov 2015 17:03

Re: PostgreSQL 13.2 and UniDac 8.4.3 BUG!!

Post by Aggie85 » Thu 06 May 2021 20:58

Devart on vacation?

AbdMSultan
Posts: 5
Joined: Mon 03 May 2021 00:09

Re: PostgreSQL 13.2 and UniDac 8.4.3 BUG!!

Post by AbdMSultan » Sun 09 May 2021 03:39

I think so ..
no answer
I am waiting for a week for some answers to my question

MaximG
Devart Team
Posts: 1632
Joined: Mon 06 Jul 2015 11:34

Re: PostgreSQL 13.2 and UniDac 8.4.3 BUG!!

Post by MaximG » Thu 13 May 2021 12:12

Sorry for not getting back to you sooner, we had long weekends. Could you please send us a sample project demonstrating the issue? For your convenience, please use the e-support form https://www.devart.com/company/contactform.html

Post Reply