Project does not build for Android debug mode

Discussion of open issues, suggestions and bugs regarding IBDAC (InterBase Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
JacobusOpperman
Posts: 9
Joined: Sun 24 Feb 2019 21:48

Project does not build for Android debug mode

Post by JacobusOpperman » Sat 08 Jun 2019 19:47

Hi! I hope someone can help! My problem is the following: I create a new blank multidevice-application. At this stage everything builds good for Android debug mode. Then I add IBCConnection and IBCQuery to the form. Now when I try to build I get the following error:

Code: Select all

[DCC Error] E2597 c:\\program files (x86)\\embarcadero\\studio\\20.0\\lib\\Android\\Release\libibtogo.a(fun.o): In function `FUN_evaluate':
  /builds/InterBase_ANDROID_TOGO_IB2017/super/jrd/fun.c:277: undefined reference to `abs'
  c:\\program files (x86)\\embarcadero\\studio\\20.0\\lib\\Android\\Release\libibtogo.a(fun.o): In function `FUN_resolve':
  /builds/InterBase_ANDROID_TOGO_IB2017/super/jrd/fun.c:947: undefined reference to `abs'
[DCC Fatal Error] F2588 Linker error code: 1 ($00000001)
Failed
Elapsed time: 00:00:45.3
There is not problem when I build for Windows but only for Android. I use Delphi Community Rio 10.3 Version 26.0.32429.4364 and IBDAC Professional 6.3.11 . I have tried to "clean" my project but it makes no difference. I hope someone can make sense of this error message and hint me in the right direction to solve it. Thank you!

ViktorV
Devart Team
Posts: 2728
Joined: Wed 30 Jul 2014 07:16

Re: Project does not build for Android debug mode

Post by ViktorV » Mon 10 Jun 2019 11:14

There is the issue in Rio, be sure to set your NDK paths to point to "android-19", not "android-14": http://docwiki.embarcadero.com/RADStudi ... e_NDK_path
See more details at: https://community.idera.com/developer-t ... bibtogo-a/

JacobusOpperman
Posts: 9
Joined: Sun 24 Feb 2019 21:48

Re: Project does not build for Android debug mode

Post by JacobusOpperman » Mon 10 Jun 2019 13:50

Thanks VictorV - problem solved!

JacobusOpperman
Posts: 9
Joined: Sun 24 Feb 2019 21:48

Re: Project does not build for Android debug mode

Post by JacobusOpperman » Tue 11 Jun 2019 03:59

Hi!
Also important: Embarcadero has released 'December 2018 IDE Patch for 10.3' to help solve this problem. You can find it at
https://cc.embarcadero.com/item/30870 .All the best for everyone on this forum!

ViktorV
Devart Team
Posts: 2728
Joined: Wed 30 Jul 2014 07:16

Re: Project does not build for Android debug mode

Post by ViktorV » Tue 11 Jun 2019 11:13

Thank you for interest to our product and your contribution in our product development.
Feel free to contact us if you have any further questions about our products.

Post Reply