"show_compatibility_56" Error

Discussion of open issues, suggestions and bugs regarding database management and administration tools for MySQL
Post Reply
toaster-loss
Posts: 6
Joined: Wed 14 Oct 2015 13:20

"show_compatibility_56" Error

Post by toaster-loss » Sun 15 Nov 2015 05:12

When I try to connect to a normal installation of MySQL 5.7.9 I get the following error:
The 'INFORMATION_SCHEMA.SESSION_VARIABLES' feature is disabled; see the documentation for 'show_compatibility_56'
I believe I can turn on show_compatibility_56, but I also read that INFORMATION_SCHEMA.GLOBAL_VARIABLES is deprecated and will be removed in a future release. Is there a better way to get dbForge to work with MySQL version 5.7 or higher other than turning this on manually?

Lucky29
Posts: 1
Joined: Mon 16 Nov 2015 07:03
Location: India
Contact:

Re: "show_compatibility_56" Error

Post by Lucky29 » Mon 16 Nov 2015 07:12

If you are selecting from information_schema tables in show_compatibility_56=OFF mode, change it to show_compatibility_56=ON

toaster-loss
Posts: 6
Joined: Wed 14 Oct 2015 13:20

Re: "show_compatibility_56" Error

Post by toaster-loss » Mon 16 Nov 2015 08:40

I'm not manually selecting information from that table, dbForge appears to be doing it behind the scenes whenever I open a connection.

alexa
Devart Team
Posts: 2278
Joined: Fri 24 Jun 2011 14:17

Re: "show_compatibility_56" Error

Post by alexa » Mon 16 Nov 2015 14:07

This version of the MySQL server is planned to be supported in the next version of dbForge.

In the meanwhile, you could try using the command line interface of dbForge or execute the following for compatibility:

Code: Select all

set @@global.show_compatibility_56=ON; 
Please also see http://dev.mysql.com/doc/refman/5.7/en/ ... ibility_56

nickweavers
Posts: 8
Joined: Tue 02 Mar 2010 19:07
Location: Southampton, UK

Re: "show_compatibility_56" Error

Post by nickweavers » Sun 14 Feb 2016 20:52

Any update on when dbForge for MySQL will support this (I'm on 6.3.358)? I understand that show_compatibility_56 is now deprecated.

.jp
Devart Team
Posts: 303
Joined: Wed 09 Sep 2009 06:55
Location: devart

Re: "show_compatibility_56" Error

Post by .jp » Mon 15 Feb 2016 11:53

Hello.
Thanks for the post.
A new version of the dbForge Studio for MySQL with the fix is scheduled to be released next week.
Best Regards.

nickweavers
Posts: 8
Joined: Tue 02 Mar 2010 19:07
Location: Southampton, UK

Re: "show_compatibility_56" Error

Post by nickweavers » Mon 15 Feb 2016 18:43

Great news!

Many thanks.

alexa
Devart Team
Posts: 2278
Joined: Fri 24 Jun 2011 14:17

Re: "show_compatibility_56" Error

Post by alexa » Wed 02 Mar 2016 14:16

We would like to let you know that dbForge Studio for MySQL, v7.0, where MySQL 5.7 is supported, is available for downloading https://www.devart.com/dbforge/mysql/st ... nload.html

Thank you for your help in improving dbForge Studio for MySQL.

nickweavers
Posts: 8
Joined: Tue 02 Mar 2010 19:07
Location: Southampton, UK

Re: "show_compatibility_56" Error

Post by nickweavers » Wed 02 Mar 2016 15:57

I have it installed already:).

Will be trying the 5.7 support soon.

Thanks for a great product.

Post Reply