Unable to uncheck unique index

Discussion of open issues, suggestions and bugs regarding database management and administration tools for MySQL
Post Reply
bsienn
Posts: 6
Joined: Tue 27 Dec 2016 12:35

Unable to uncheck unique index

Post by bsienn » Tue 27 Dec 2016 13:03

While creating index, by default the unique checkbox is checked.
Unable to uncheck unique index check mark.

Also table names doesn't retain camel notation...?

Column already exist, already mentioned in this thread.
viewtopic.php?f=23&t=34759

alexa
Devart Team
Posts: 2279
Joined: Fri 24 Jun 2011 14:17

Re: Unable to uncheck unique index

Post by alexa » Tue 27 Dec 2016 15:04

While creating index, by default the unique checkbox is checked.
Unable to uncheck unique index check mark.
You need to unselect the 'Unique' property in the right section of the window.
Also table names doesn't retain camel notation...?
Column already exist, already mentioned in this thread.
viewtopic.php?f=23&t=34759
We will investigate this when developing the next product builds.

bsienn
Posts: 6
Joined: Tue 27 Dec 2016 12:35

Re: Unable to uncheck unique index

Post by bsienn » Wed 28 Dec 2016 10:15

Thanks Alexa.

Didn't noticed the unique check mark on right side. Thanks working as intended.

alexa
Devart Team
Posts: 2279
Joined: Fri 24 Jun 2011 14:17

Re: Unable to uncheck unique index

Post by alexa » Wed 28 Dec 2016 11:13

Thank you for the reply. Please let us know if any questions arise.

bsienn
Posts: 6
Joined: Tue 27 Dec 2016 12:35

Re: Unable to uncheck unique index

Post by bsienn » Wed 28 Dec 2016 14:39

alexa wrote:Thank you for the reply. Please let us know if any questions arise.

Hi Alexa,

Updating column as unique doesn't work. had to update through query. Please note.

alexa
Devart Team
Posts: 2279
Joined: Fri 24 Jun 2011 14:17

Re: Unable to uncheck unique index

Post by alexa » Wed 28 Dec 2016 15:03

Could you please clarify it and describe the steps to reproduce step by step? Screenshots would be also of help.

You can send a reply straight to our support system at supportATdevartDOTcom and alexaATdevartDOTcom

bsienn
Posts: 6
Joined: Tue 27 Dec 2016 12:35

Re: Unable to uncheck unique index

Post by bsienn » Thu 29 Dec 2016 06:52

alexa wrote:Could you please clarify it and describe the steps to reproduce step by step? Screenshots would be also of help.

You can send a reply straight to our support system at supportATdevartDOTcom and alexaATdevartDOTcom
Hi Alexa,

Regarding the tablename being converted to lowercase, I just searched and found that its not dbForge issue; its actually related to mysql configuration on windows. by default its configured to convert table names to lowercase. setting lower_case_table_names = 2 in my.ini of mysql allows uppercase table names.

Regarding the unique check mark issue, the unique was not applying on the column as there was unique index already applied.

If the unique won't apply if there is an unique index, than maybe there should be a prompt telling unique index already applied, better disable the unique check mark in case of unique index already applied.

Everything else is working fine. Thanks for your quick response and time helping me out.
I'm a new developer and dbForge Express user, sorry for misunderstanding.

Happy new year Alexa :)

alexa
Devart Team
Posts: 2279
Joined: Fri 24 Jun 2011 14:17

Re: Unable to uncheck unique index

Post by alexa » Thu 29 Dec 2016 11:57

Thank you for the reply.

We will take this into account.

A happy new year to you too.

Post Reply