Disabling Table Alias Generation

Discussion of open issues, suggestions and bugs regarding database management and development tools for Oracle
Post Reply
mooman858
Posts: 6
Joined: Wed 30 Jan 2019 17:03

Disabling Table Alias Generation

Post by mooman858 » Wed 30 Jan 2019 17:21

Where do I go to disable table level alias generation.

I see an older question which says the option is here:
Please perform the following:
  1. Select 'Tools -> Options...' from the main menu. The 'Options' window opens.
  2. Navigate to the 'Text Editor -> Code Completion -> Alias' section.
  3. Unselect the 'Generate alias on commit' option.
  4. Click 'OK'.
Found here: viewtopic.php?f=22&t=35166

In version 4.0.304 (2018) the option is not there. Can you tell me where it was moved to, as I am having trouble finding it. I see a column level option at this menu but not table level.

Thanks in advance =)

alexa
Devart Team
Posts: 2885
Joined: Fri 24 Jun 2011 14:17

Re: Disabling Table Alias Generation

Post by alexa » Mon 04 Mar 2019 14:15

Could you please let us know what edition of dbForge you are using and provide us the screenshots of the actual and expected results?

You can send a reply straight to our support system at alexaATdevartDOTcom and supportATdevartDOTcom .

mooman858
Posts: 6
Joined: Wed 30 Jan 2019 17:03

Re: Disabling Table Alias Generation

Post by mooman858 » Tue 05 Mar 2019 21:00

I will do that. Thank you for the reply.

mooman858
Posts: 6
Joined: Wed 30 Jan 2019 17:03

Re: Disabling Table Alias Generation

Post by mooman858 » Thu 18 Apr 2019 14:54

I just want to add that this was fixed as of dbForge Studio for Oracle, v4.1.

alexa
Devart Team
Posts: 2885
Joined: Fri 24 Jun 2011 14:17

Re: Disabling Table Alias Generation

Post by alexa » Fri 19 Apr 2019 14:50

Thank you for updating us on this issue.

Please let us know if any questions arise.

mooman858
Posts: 6
Joined: Wed 30 Jan 2019 17:03

Re: Disabling Table Alias Generation

Post by mooman858 » Wed 22 May 2019 13:44

brandscill, I found this option under:
Open the Options window:
  1. Select Tools -> Options... from the main menu. The 'Options' window opens.
  2. Navigate to the Text Editor -> Code Completion -> Alias section.
  3. Uncheck both check boxes there
  4. Optional: Go to the Advanced section above Alias and set those options as well

mooman858
Posts: 6
Joined: Wed 30 Jan 2019 17:03

Re: Disabling Table Alias Generation

Post by mooman858 » Wed 22 May 2019 14:42

Sorry, I don't see the image. I am using the Standard version. Is that what you are using?

mooman858
Posts: 6
Joined: Wed 30 Jan 2019 17:03

Re: Disabling Table Alias Generation

Post by mooman858 » Wed 22 May 2019 15:22

Hmph... I guess I am not sure what to say here. Maybe alexa will chime in? You can always contact support as well. They usually answer within a day or two.

alexa
Devart Team
Posts: 2885
Joined: Fri 24 Jun 2011 14:17

Re: Disabling Table Alias Generation

Post by alexa » Thu 23 May 2019 05:48

The issue appears to be present only in the Professional edition.

We will fix it in one of the next product builds and will notify you once it's available for downloading.

brandscill
Posts: 1
Joined: Thu 01 Aug 2019 12:53

Re: Disabling Table Alias Generation

Post by brandscill » Thu 01 Aug 2019 12:55

So over 2 months now, when this will be fixed? How can you charge $450 for a product and offer zero support?

alexa
Devart Team
Posts: 2885
Joined: Fri 24 Jun 2011 14:17

Re: Disabling Table Alias Generation

Post by alexa » Fri 02 Aug 2019 09:48

We do apologize for the delay on this.

We will prepare a custom build with the fix for you shortly.

Post Reply