Schema Comparison not seeing Triggers/Sequences

Discussion of open issues, suggestions and bugs regarding database management and development tools for Oracle
Post Reply
to11mtm
Posts: 5
Joined: Sat 14 Mar 2015 18:21

Schema Comparison not seeing Triggers/Sequences

Post by to11mtm » Tue 01 Dec 2015 21:55

I am attempting to use DBForge Fusion to compare two schemas. However, when I do so, all of the triggers and sequences are being shown as 'new' and not updated or unchanged, despite them being the same, and the sequences being present.

For whatever it's worth, I'm in direct mode on both databases; I've tried against both a 11.2.0.3 to a 10.2.0.5 as well as a 11.2.0.3 to 11.2.0.3, with the same results on both.

alexa
Devart Team
Posts: 2429
Joined: Fri 24 Jun 2011 14:17

Re: Schema Comparison not seeing Triggers/Sequences

Post by alexa » Wed 02 Dec 2015 16:30

Could you please provide us the following information:

1. Version of dbForge.
2. Version of Visual Studio.
3. The CREATE definition of the trigger and sequence.
4. Screenshot of the comparison displaying the objects in the "Only in Source" and "Only in Target" sections.

You can reply straight to our support system at supportATdevartDOTcom

to11mtm
Posts: 5
Joined: Sat 14 Mar 2015 18:21

Re: Schema Comparison not seeing Triggers/Sequences

Post by to11mtm » Wed 02 Dec 2015 20:44

Alexa,

Thanks for the quick response! I actually discovered the problem; the login I was using for the target database did not have the SELECT_CATALOG_ROLE granted properly. Once this was taken care of the triggers and sequences were properly noticed/cataloged.

alexa
Devart Team
Posts: 2429
Joined: Fri 24 Jun 2011 14:17

Re: Schema Comparison not seeing Triggers/Sequences

Post by alexa » Thu 03 Dec 2015 14:55

Thank for updating us on this issue.

Please let us know if any questions arise.

Post Reply