Command Line does not recognize the Secondary Unique Index

Discussion of open issues, suggestions and bugs regarding database management and development tools for Oracle
Post Reply
NavilleD
Posts: 6
Joined: Tue 03 Mar 2015 21:33

Command Line does not recognize the Secondary Unique Index

Post by NavilleD » Thu 07 May 2015 14:15

Hi,

I am working with DBForge for Oracle, I came across this strange issue while I had a Table which had 2 Unique Indexes, So now I have a .DCOMP for each Index, when I see the results from the UI. It seems like it is doing what is desired (using the respective index) whereas when I run it through command line, it does not seem to recognize the second index and ends up giving same report for both the .dcomps.

Please help me understand why thisis happening and if there is any solution to taht please let me know.

alexa
Devart Team
Posts: 2424
Joined: Fri 24 Jun 2011 14:17

Re: Command Line does not recognize the Secondary Unique Index

Post by alexa » Thu 07 May 2015 15:27

Could you please provide us a screenshot of the error and the CREATE definitions of the table for both Source an Target?

You can send a reply straight to our support system at supportATdevartDOTcom and alexaATdevartDOTcom

NavilleD
Posts: 6
Joined: Tue 03 Mar 2015 21:33

Re: Command Line does not recognize the Secondary Unique Index

Post by NavilleD » Thu 07 May 2015 19:16

I do not get any error the comparison runs fine, however the Secondary Unique Index is not being used, while I run through the Command Line.

Here is the Example:
I have a table named ITEM which has 2 unique indexes, ITEM_NDX1 and ITEM_NDX2, so in order to compare the table, I have 2 different dcomp files, and When I run them throught the DBFORGE tool, I get different results(which is right), and then when I run them through the command line, I get the same results for both the runs.

The Secondary Unique index is not being recognized, I dont know whether I can send the Scripts here or not

alexa
Devart Team
Posts: 2424
Joined: Fri 24 Jun 2011 14:17

Re: Command Line does not recognize the Secondary Unique Index

Post by alexa » Fri 08 May 2015 11:48

You can send the scripts to supportATdevartDOTcom and alexaATdevartDOTcom

Also, please provide us the command line string and the *.dcomp document.

Post Reply