Lastest release is causing me problems. HELP!!

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for MySQL
Post Reply
Posts: 5
Joined: Sat 22 Jan 2005 15:56

Lastest release is causing me problems. HELP!!

Post by FlashHeart » Tue 08 Mar 2005 07:53


I have a real problem here. 2 weeks ago I upgraded to the latest version of the components (v2.70.3.0) and now I get the following problems but ONLY for projects that I originally built and compiled with the PREVIOUS version of the components (new ASP.NET and Windows forms projects work ok):-

1. I drop a MySqlDataAdaptor onto an ASP.NET page and select 'Configure Data Adaptor' from the properties page. In the properties window that appears I type in any SQL into the select command, hit OK and hit 'No' at the prompt asking if I want to regenerate the parameters. On hitting 'No' I get a message box telling that there are 'no suitable connections on form to use' even though there are!

2. I click on an existing MySqlDataAdaptor (one that I put on an page before the upgrade) and go to its properties window and expand the SelectCommand properties click on the elipsis button for the SelectCommand's parameters. When I click on the elipsis I get error 'Specified cast is not valid'.

3. When I compile the project after adding and removing data adaptors (trying to figure out the problem) a new task appears in the VS task list but the compilation still completes OK :-

Code generation for property 'Parameters' failed. Error was: ''MySqlParameterConverter' is unable to convert 'CoreLab.MySql.MySqlParameter' to 'System.ComponentModel.Design.Serialization.InstanceDescriptor'.'

I only noticed these problems yesterday because I've done no development for a few weeks.

I'm using VS 2003 and these problems occur on both of my development PCs. I've even loaded a backup of my project and it has the same problems. This is all a serious problem for me because have a big ASP.NET project that needs to rolled out in beta form this week! Any help would be greatly appreciated.

Many Thanks



Post by Serious » Wed 09 Mar 2005 13:06

Try to reinstall MySQLDirect .NET. Check before that MySQLDirect isn't installed and there are no CoreLab.MySql.dll, CoreLab.MySql.Addin.dll, CoreLab.MySql.Design.dll files in GAC.

Posts: 1
Joined: Mon 09 May 2005 17:27
Location: Northern Hemisphere Sol 3

Post by xspert1 » Thu 12 May 2005 20:13

I'm Running and am getting the same result as above. It's not totally crippling. I just want it fixed. I have tried reinstalling, ensuring the GAC is clear and other items in the forum. How can I get the Data Adapter working?


Post by Serious » Mon 16 May 2005 11:07

1. Open "Configure Data Adapter" dialog.
2. Run new instance of Visual Studio and attach to process of first Visual Studio (where you opened "Configure Data Adapter" dialog) (menu "Tools"/"Debug processes").
3. Select "Common language runtime" option in the "Attach to process" dialog.
4. Open "Modules" window (menu "Debug"/"Windows"/"Modules").
5. Ensure that all "corelab*" modules have version.
6. If some modules have another version note their paths and delete them after both instances of Visual Studio are closed. Reinstall MySQLDirect .NET.

Post Reply