ASP.NET Provider login problem

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for MySQL
Post Reply
Posts: 1
Joined: Mon 05 Jun 2006 19:05

ASP.NET Provider login problem

Post by monkamonka » Mon 05 Jun 2006 19:15

I have the mysqldirect 3.50 and an series of pages. I have setup the proper users and roles to allow myself to view pages. I have also configured the machine.config with the appropriate connection string. I am using Visual Studio 2005 and when I use the development host to test the site, it works perfectly. However when I publish the site to the same computer, which is also the server, it no longer works from the local computer or a remote computer on the network.

It prompts me for the username and password like normal, however, when I input this, it says "ypur login attempt was not successful. Please try again."

I cannot figure out what is going wrong.

Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Post by Alexey » Tue 06 Jun 2006 12:09

Please check your connection settings, machine.config settings, whether needed provider is attached; try to create a user.

Posts: 19
Joined: Sat 13 May 2006 04:11

Post by TillmanZ » Mon 12 Jun 2006 11:04

My guess is that your applicationname on the local server is different from the actual applicationname of your ASP.NET project.
If you look at the accesslist tables you will see that it's not only the Username/PW combination that will grant access, but also the applicationname is checked.
So if you change the applicationname of that virtual directory in your local IIS settings then I am pretty sure that it's gonna work.

Good luck

Post Reply